Custom scheduling not working using CMS 1.8.2

Custom scheduling not working. I am using CMS ver 1.8.2 on XAMPP on windows 7 as trial server and windows 7 as clients. I tried adding orders and priorities and nothing worked.

Your support is highly appreciated.

Best regards
Asser Mehrez

What do you mean by ‘custom’ scheduling exactly please?

Also by ‘nothing worked’ you mean that player was displaying only the default layout?

Can we see a screenshot of the event(s) that you’ve created and screenshot showing player status window please?
you can also have a look at schedule.xml inside player local library.

Dear Peter,

By custom scheduling, I mean scheduling a layout that have a definite start time and a definite End time.
i.e. not the “Always” option

by nothing worked, that it is the “Always” event scheduled or the default layout only work despite adding proper ordering and priority to the event with the" Custom" scheduling option

Here what you requested for the display (BMehrez-PC) status

and at the last a copy schedule.xml

<?xml version="1.0"?>
<schedule generated="2017-09-02 09:54:06" fitlerFrom="2017-09-02 00:00:00" fitlerTo="2017-09-02 00:01:00">
  <default file="8">

where there is no any traces of the event with the scheduling except the default.

I apologize for the delay, as it was holidays over here

Best Regards
Asser Mehrez

Since you have /web in your CMS url, please have a look at DocumentRoot and URL rewriting here -

The above is the first item you should fix.

Your schedule.xml only mentions the default layout nothing about scheduled layouts always or otherwise.

The screenshots that I’d like to see are:

  1. Schedule Page -> Click on the scheduled event to see edit event from
  2. Player status window, I mean, when your player runs and is displaying your layout, press ‘i’ on your keyboard to show status window, that’s what I’d like to see.

Perhaps also make sure that CMS/server timezone is matching your player timezone so we know there is no problems there.

Well, I am using XAMPP over Windows 7 as the Web server

Kindly note that your portal only permits one image to be added, so I added the more important one

for the time being, I am plying the client at the server. So that they have the same timing.

Best Regards
Asser Mehrez

^ that should be your first move.

On that page you will also find link to XMR/XTR configuration which you should take a look at as well.

I assume layoutId 8 is the default layout for the display?

After that’s sorted, please try to schedule a different layout to your player (ie different than layoutId 8) and see if it will show it.
On Schedule event edit form, there is also ‘Use CMS time…’ checkbox, please see if it makes a different when it’s enabled/disabled, but if the CMS and server and player are all set to the same timezone then it should be fine.

Ok so let’s focus on the first step.

After reading the link you included (, appreciate specifying what is wrong with the environment I am using?

Best Regards
Asser Mehrez

DocumentRoot is not set correctly, as you should not need to access CMS with /web in the url.

Which probably implies that URL rewriting isn’t configured as well.

well I can access the application successfully, and I appreciate if you could let me know what this has got to do with scheduling

By exposing the “web” folder, the URL rewrite rules that the CMS relies on to function will be broken, which will prevent the CMS from working as expected.

You need to fix this first before we can progress.

Hello Peter, & Alex,

I modified the document root in the httpd.con and here is the result attached.

That’s a step in the right direction. I’d clear your web browser cache now to ensure you have a clean slate to work from.

That is only true for new users. The welcome message you will have received explains that you need to level up as new user to unlock certain features - which helps to prevent robot signups from posting lots of random SPAM here.

Simply searching and reading other threads is enough to do this.