Custom schedule isn't working?

Dear Xibo Staff,

Just to be sure, a schedule with dayparting “custom” isnt working right?
I tried to set a custom schedule and it doesnt appear on the schedule…

I’ve upgraded yesterday to 1.8.8.

ps: Thanks for the “Authorise” button. :hugs:


On your Schedule page, have you selected the display you are testing on from the display selection list ?

Does the same issue occur when you schedule an event having Dayparting set to = Always ?

Thank you Kenneth for your answer.

I usually click the green button located in the Schedule page, “Add Event”. If I choose to “schedule now” a campaign, and I choose how Long in minutes or hours, the custom schedule works. Using the Always dayparting everything working as expected.

Anyway If I’m not wrong, this is already a know bug, I just wanted to clarify if it is my installation or it’s a release bug…

PS: Yes, I always choose “all” or the monitor/group on the top, to reveal my Scheduled event, but I think it’s more deep the problem, is not a filter related issue… (I beleive, in my humble experience)


I updated to 1.8.9 and the custom schedule isn’t working. Maybe you can add a custom schedule using time range, starting from campaigns and selecting “Schedule now”, but is not easy to set up, if you need to choose a specific day.

That’s not correct I’m afraid, there is no general problem in 1.8.9 with custom scheduling.
There is one minor issue with scheduling in current version, but it’s not related to the problem you seem to be encountering.

Is it docker or custom installation? What web browser are you using? Do you see an error when you add an event? Does the form closes properly?

Are you certain that’s not just a browser cache issue? ie does the scheduled events are not send to the players after you create them?


Firefox 59.0.3 (64 bit)

No unfortunately. It gives me a good message “Event Added”, but it not added in the calendar/schedule.

Yes, if you are talking about the “Schedule Event” window. After I filled it up, I click the blu save button and it closed, returning the above message. Everything seems fine, but the event isnt added.

Thanks for this suggestion. I tried to set a custom schedule with another computer, and with a fresh browser, but nothing happens. I mean, ok message, but nothing is added in the scheduler.

Thanks so much for help

I’m intrigued.

Is your CMS available over the internet? If so could you grant me a temporary access to it (via private message) so I can see it first hand?
Alternatively I can connect via TeamViewer to a PC that has access to the CMS if that’s easier.

If any of those options is feasible, please do let me know the details via private message.

Ofcourse, thanks so much… I’m really unhappy :sweat_smile: cause the Day I found the way to manage Campaigns (a way to organize a year without touching the planner), they are not working for me. Anyway I’ll send the credentials for checking out my installation.

I believe I’ve fixed the problem, details in private message.

In short for anyone else watching this topic, the events were created, but they were created not on the desired date - it was caused most likely by a incorrect date format in CMS settings.

I thought that setting was used only for showing date. I’m sorry :sweat_smile:

Now its working perfectly.
Thank you Peter