Couldn't connect to Docker Daemon

Good morning,

I have come in today to strange issue. Tried to get onto the CMS and was greeted with a this site can’t be reached message from chrome. Jumped onto the host machine and tried to investigate, ran docker-compose up -d and got the message

“Couldn’t connect to Docker daemon. You might need to install Docker”

Everything was fine before the weekend, nothing has restarted it self?

Any ideas,


I’d check the docker daemon is running. You don’t say if it’s Windows or Linux so I can’t really assist you in how to proceed.

Hi Alex,

Sorry, it’s running on Ubuntu 16.04 LTS


service docker status

Will show you the status then.

service docker start

will start it if it isn’t running.

Perhaps you have the system set to apply security updates automatically, and that applied a new version?

Serveice Docker Status returned docker.service changed on disk, run systemctl daemon-reload to reload docker service.

I have done that and then tried “service docker start” but get "Failed to start docker.service: Unit docker.service is masked.

service docker status now returns Loaded: masked (/dev/null; bad)
Active: inactive (dead)

It’s not something I’ve seen personally. It implies that something disabled the service. I would check your logs to see what occurred last night.

That suggests running:

systemctl unmask docker.service
systemctl unmask docker.socket
systemctl start docker.service

I suspect it may also require

systemctl enable docker.service

To ensure the service starts on reboot too.

1 Like


Not it’s really broke!

I have already found that page and was trying ti when you replied but now im getting

I think I might just give up and move to docker for windows, as I’m really not an expert on Linux, although it would be googe to get it running to I can export everything!

You need to look at the log and see why it isn’t starting.

But first you need to look and see what happened last night to trigger this…

If you’re able to give me reasonable remote access I don’t mind having a look for you.

Hi Alex,

That would be great, happy for you to have remote access.


Can you give me a PM with details then please.

Docker had been uninstalled by automatic updates. Reinstalled and recreated the containers to get it back up and running.

Thanks so much for your help Alex, much appreciated.

Thank You.
systemctl enable docker.service
works fo me.