Configuration Error


I am having a problem with the CMS 1.8.7.

When I access to Login. It shows:

I can’t see logs, I can’t login to xibo_admin.

I have installed the CMS using Docker Win 10-64bits, I have shared the drives and I aware of the bug when Windows restart.

I had this problem a weeks ago, but I had chance to delete and to set up the server. Now, I can’t do it. The system was working fine for several weeks.

Does someone know about this bug?


It looks like a filesystem permission issue to me. Perhaps something changed the filesystem permissions on your shared directory?

Hello @alex

I have checked and the shared directory has permissions.

These are the shared directories:

image: xibosignage/xibo-cms:release-1.8.7
- “./shared/cms/custom:/var/www/cms/custom”
- “./shared/backup:/var/www/backup”
- “./shared/cms/web/theme/custom:/var/www/cms/web/theme/custom”
- “./shared/cms/library:/var/www/cms/library”
- "./shared/cms/web/userscripts:/var/www/cms/web/userscripts"
restart: always

Is there any file log where I can search more detail about the error?

The error is telling you that it can’t write to the library directory so you do have a file system permission issue which you need to resolve. It has nothing to do with the docker-compose file

Yes, I understand and for the same reason I have checked permissions and They are ok.

However, I have created other container in the same directory, and the new CMS container is working and saving the new information. So I am thinking, it isn’t a permission issue.

Maybe a missing file?
So, again, is there a log file where can I look for?

Thank for your help.

If you down and up the container it will be created fresh. It cannot have any missing files

Thank you Alex.

I couldn’t find my mistake.

I executed down and up for the container, and the same error showed.

Removing the shared library, I could log in xibo admin and reconfigure the server, fortunerly the server doesn’t have too many screens. I tried to restore from backup, but it showed the same error, I had to import manually the files in library.

Now, It’s working again the server, but I am not sure for how much time.

Thanks for reading, if you have any other idea, let me know.