CMS Status X and problem to send Command


I Use RedHat 7.3, Xibo CMS 1.8.1 is running on this server. when i can’t send command to the Player, I can’t recen Screen Shot and Thumbnail from Player.

In the Player : XMR Status : connected to tcp://10.xx.xx.xx:9505 (10.xx.xx.xx is mys CMS IP)

I try to XMR.PHAR /var/www/html/xibo/vendor/xibosignage/xibo-xm

r/bin byt i receive this messageUploading…

conig.json in /var/www/html/xibo/vendor ins configured like this

“listenOn”: “tcp://localhost:50001”,
“pubOn”: [“tcp://mycmsIP:9505”],
“debug”: false

can you hel Me to solve this problem please.


Do you have the same public/private addresses in CMS Settings?

Are you using Android or Windows clients? (I assume they are in 1.8.1 / 1.8R102 version as well?)

What errors do you see in CMS logs / player status when you try to push player action (screenshot/command etc)?

The window shows “Missing config.json”. The config.json is misplaced in the wrong directory, I think

I hav the same Publi/Private Adress en CMS setting.

I use Windows Client
when i send comman / screenshot the buttum Save turn No error message


config.json is in this directory:


That private address in CMS settings does not seem to be the same as in the xmr config…

and yes config.json with xmr configuration should be in vendor/bin

Directory: vendor/bin

Both files I have in there:

Hi Peter!
this is my config.json in xibo/vendor/bin

10.xx.xx.xx is my CMS adress. it’s the same adress that i put in CMS setting.

XMR Publi adres et Private Adress is the same


XMR Private Address: tcp://localhost:50001
XMR Public Address: tcp://

Thanks i change adress in CMS but no think change i c’ant send command, screenshot… to Player

You must also solve the problem with Missing config.json, see message in command window (PHP fatal error)

config.json must be in vendor/bin
bur when i un xmr.phar in …xibo/vendor/xibosignage/xibo-xmr/bin/
error returned is

anather conig is nessacery in …xibo/vendor/xibosignage/xibo-xmr/bin/ ?

The error message tells you exactly where the config.json file needs to be :slight_smile: Put it there.