CMS errors after upgrade

I have just upgraded from 1.8.12 to 2.0.1. I followed this steps Manual/Custom Install | Xibo Digital Signage
I had a problem, but I can solve it following this steps
Upgrading to xibo v2, unable to do database migrations

Now the CMS has some errors.
1. All values of location (in Display Setting Profiles) have been erased. I tried add new values, I clicked on save button without errors, but changes aren’t saved.
2. I can’t change setting values. When I click on save button an error message appears.

Error message after I change SERVER_MODE value in DB.
Constant SECRET_KEY already defined#0 /var/www/html/ Slim\Slim::handleErrors(8, ‘Constant SECRET…’, ‘/var/www/html/x…’, 23, Array)
#1 /var/www/html/ require(‘/var/www/html/x…’)
#2 /var/www/html/ include(‘/var/www/html/x…’)
#3 /var/www/html/ Phinx\Config\Config::fromPhp(‘/var/www/html/x…’)
#4 /var/www/html/ Phinx\Console\Command\AbstractCommand->loadConfig(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput))
#5 /var/www/html/ Phinx\Console\Command\AbstractCommand->bootstrap(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput))
#6 /var/www/html/ Phinx\Console\Command\Status->execute(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput))
#7 /var/www/html/ Symfony\Component\Console\Command\Command->run(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput))
#8 /var/www/html/ Symfony\Component\Console\Application->doRunCommand(Object(Phinx\Console\Command\Status), Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput))
#9 /var/www/html/ Symfony\Component\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput))
#10 /var/www/html/ Phinx\Console\PhinxApplication->doRun(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput))
#11 /var/www/html/ Phinx\Wrapper\TextWrapper->executeRun(Array)
#12 /var/www/html/ Phinx\Wrapper\TextWrapper->getStatus()
#13 /var/www/html/ Xibo\Helper\Environment::getMigrationStatus()
#14 /var/www/html/ Xibo\Helper\Environment::migrationPending()
#15 [internal function]: Xibo\Middleware\State->Xibo\Middleware{closure}()
#16 /var/www/html/ call_user_func_array(Object(Closure), Array)
#17 /var/www/html/ Slim\Slim->applyHook(‘slim.before.dis…’)
#18 /var/www/html/ Slim\Slim->call()
#19 /var/www/html/ Slim\Middleware\Flash->call()
#20 /var/www/html/ Slim\Middleware\MethodOverride->call()
#21 /var/www/html/ Xibo\Middleware\Actions->call()
#22 /var/www/html/ Xibo\Middleware\Theme->call()
#23 /var/www/html/ Xibo\Middleware\WebAuthentication->call()
#24 /var/www/html/ Xibo\Middleware\CsrfGuard->call()
#25 /var/www/html/ Xibo\Middleware\State->call()
#26 /var/www/html/ Xibo\Middleware\Storage->call()
#27 /var/www/html/ Xibo\Middleware\Xmr->call()
#28 /var/www/html/ Slim\Slim->run()
#29 {main}

My Environment
Xibo Version 2.0.1
PHP 7.0.33 (cli) (built: Apr 30 2019 13:10:17)
Operating System: CentOS Linux release 7.6.1810.2.el7.centos.x86_64
Linux Kernel: 3.10.0-957.12.1.el7.x86_64
CPU: Intel® Core™ i7 CPU 870 @ 2.93GHz
RAM: MemTotal: 16163660 kB

upload_max_filesize = 5000M
post_max_size = 1000M
max_file_uploads = 50
memory_limit = 8000M
max_execution_time = 9400
max_input_time = 9400

Does the url you use to access the CMS end in /web ?
Also do you see multiple SECRET_KEY in settings.php file?

1 Like

I already fix error 2 (can’t change setting values)
I create a symlink for the url /web .

I’m working on fix error 1 (All values of location (in Display Setting Profiles) have been erased)

I have decided to try upgrade again from 1.8.13 to 2.1.0

All values of location (in Display Setting Profiles) have been erased. I tried add new values, I clicked on save button without errors, but the changes aren’t saved.

I can add new profile and its work fine, the problem was with old profiles.
I watched my SQL Backup and I found one little difference, see the picture

So, I made the corresponding changes for fix the issue.