Client screenshot defaulting to 0

I am running CMS 1.8.9 (Docker). Under Display Settings I had “Request Screenshot” set to 5 minutes and it was working. I noticed that no screen shots were being updated in the list of displays. So returning back to Display Settings, it appears that the Request Screenshot time was set to 0 and does not appear to let me change the value.

As a test I created a new Display Settings profile, and set everything the same, except set the Request Screenshot to 5 minutes. I assign a display to it, and return to the Display Settings profile, and alas, it is set back to 0 as well.

I’m wondering - is there an issue with my configuration that is causing it to fail and revert to 0? I have enabled diagnostic logging and as far as I can tell I don’t see any messages pointing me in any particular direction. I’ve (temporarly) set the library/screenshots shared folder on the CMS docker container to 777 (in case it was a file write problem). Didn’t seem to make a difference.


I don’t seem to have this problem locally.

Just in case, which profile type is it please?
When you just edit the profile & Save and then reopen it does it show the 0 already?
I assume no errors are displayed and the profile is saved fine?

Is that the only setting that is reverting back to the default value?

It would seem like for some reason it is setting the default config value there, that’s rather strange.

Yes I’ve never had this issue before - just noticed it after I updated our CMS to use the Docker version. Our custom installation was working just fine. It is the Windows profile. So I tried creating a new version of the Windows profile (with all the same settings) and then setting it to default. I set the screen shot interval to 5 minutes. Went back in, and the screen shot interval was set to 0, and the value 0 is just text, it is not in a text box allowing me to change the value. I don’t see any other values doing the same thing.

I should add that the Docker version of hte CMS was providing me screen shots for a while, but then stopped and this started. Before looking at the config profile, I was checking permissions and file ownership on the CMS exposed directories of the docker droplet.

I don’t see any errors being logged that would lead me to the root cause. I checked out the Android display profile (which we don’t currently have any displays connected to) and the drop down for a selection of time is there as expected.

I’d try clearing your browser cache, and disabling any browser extensions that might be trying to auto-fill fields on the form.

Hello Alex - I did try clearing the cache - and trying on a different computer / browser etc - all the basic troubleshooting things.

To clarify, it’s not auto-filling - it’s just not letting me select or change anything

… please see screen shot …

I see from your screenshot, it’s simply that that field is disabled. It’s not an input box that you can edit like the ones below it.

You need to go to the CMS Settings Page, Displays tab, and then ensure “Enable the option to set the screenshot interval?” is ticked.

Then you’ll be able to edit that value.

How should I type out the words which I just yelled? I can’t believe I missed this. Kind of a weird option though!

Thank you once again Alex. I can always count on you.

It’s a really useful option actually.

Having the Player send 1080p or 4K screenshots back to the CMS every minute can use a huge amount of bandwidth, and some admins or service providers don’t want their users to be able to do that, especially where their Players are on mobile internet links for example, so we provide a way to disable editing that field.