Changing server of Xibo installation


I want to change the server on which I’m running Xibo. Both servers are Ubuntu 14.04.1 LTS and my Xibo version is 1.7.7. I have dumped my MySQL database, copied the folder xibo-library and xibo-cms-1.7.7 to a new server. The problem is that when I try to open Xibo on a new server, I get an error saying:

Fatal error: Uncaught exception ‘Stash\Exception\InvalidArgumentException’ with message ‘Failed to create cache path.’ in /home/sasa/xibo-cms-1.7.7/3rdparty/stash/src/Stash/Utilities.php:225 Stack trace: #0 /home/sasa/xibo-cms-1.7.7/3rdparty/stash/src/Stash/Driver/FileSystem.php(176): Stash\Utilities::checkFileSystemPermissions(’/xibo-1.7.7-lib…’, 504) #1 /home/sasa/xibo-cms-1.7.7/lib/app/pdoconnect.class.php(149): Stash\Driver\FileSystem->setOptions(Array) #2 /home/sasa/xibo-cms-1.7.7/lib/include.php(133): PDOConnect::configureCache(NULL, NULL) #3 /home/sasa/xibo-cms-1.7.7/index.php(23): include_once(’/home/sasa/xibo…’) #4 {main} thrown in /home/sasa/xibo-cms-1.7.7/3rdparty/stash/src/Stash/Utilities.php on line 225

I have imported the MySQL database and created the user that is in the settings file. Does anyone know what this error means? Thanks.

check and grant www user write permission on folder.

I did that. www user is www-data and I have “chown” all files and folders to the user www-data. I have even tried putting chmod 777 on all files and folders but the error stays…

Did you ever find a solution? I have the exact same issue since Xibo added the 3rd party library Stash. Can’t get any version with Stash to work. 1.7.4 IIRC is the last version that works for me.


got the same error :

Fatal error: Uncaught exception
’Stash\Exception\InvalidArgumentException’ with message ‘Failed to
create cache path.’ in
Stack trace:
Stash\Utilities::checkFileSystemPermissions(’/opt/xibolib/ca…’, 504)
#1 /var/www/html/xibo/lib/app/pdoconnect.class.php(149):
#2 /var/www/html/xibo/lib/include.php(133):
PDOConnect::configureCache(NULL, NULL)
#3 /var/www/html/xibo/index.php(24): include_once(’/var/www/html/x…’)
#4 {main}
thrown in /var/www/html/xibo/3rdparty/stash/src/Stash/Utilities.php on line 225

database and settings.php export. Fresh install of centos 7 import database and settings.php then trying to upgrade… Did I miss something ?

any solution to that ?


For those who got the same problem. Check your xibo library path, It had to be the same on new and old server (check permissions as well)

(thx to dan for the solution)

Good luck :smile: