Change of SSL Certificate not possible

Hello Community,

after change to version 1.8.3. in dec. 2017,
now we had to change our SSL certtificate but after change to the new one, the clients couldn’t connect to Xibo. The clients fault will be: “trust anchor not given”
The old cert was bundled and root-signed.

If we do the same with the new certificate the Problem happen, but if we roll back the changement it works.

Maybe anyone of you had similar Probs and know a solution ?

Argh… you need Specs: Xibo in Docker as the Manual prefers :wink: and the base is a Debian.

Thanks for your help!

Could you tell me if your SSL enabled server is publicly available and if so could you share the name of it with me over private message (or here, but perhaps it would be better of private message).

After that, I’d also like to know if it is self-signed certificate or "trusted’/‘proper’ certificate, if it is the latter are the intermediate certificates installed correctly as well?

We would also need to know which SSL protocols have you got enabled?

You can also test the server by yourself:

Test your server here

That should tell you where the issue is, if it’s issue with certificate chain, you can test it here

Hello Peter,

at first thanks for your answer.

Yes, the server is public available, but currently we switched to the old certificate (that works) and to answer your question: The certificate ist not self-signed it’s trusted by RapidSSL.
Our mainproblem is that we use older android machines with Xibo Client and they don’t trust the Chain, although we use root+intermed+ssl in a bundle. A workaround would be to accept these Certificates directly in Android, but this is nearly impossible, because the machines in different cities.