Can't login to localhost

When I run docker-compose up -d
I should be able to goto a web browser and enter localhost to login to the cms for the first time. All I get is a Firefox can’t establish a connection to the server at localhost.


Is the Docker install on the same machine as your web browser is running on? Or is that an SSH session in the background?

What does docker ps show?

The docker install is on the same machine as web browser. No ssh session is running.

The docker ps command shows the cms ip as on port 80
I tried to change the ip in the docker-compose.yml file to “” and it keeps giving me the error as well.

I ran ifconfig to check that my local host ip is
I also entered into the web browser and get the same Firefox can’t establish a connection to the server at or http://localhost/

You don’t need to adjust the network settings. will work fine.

See in the screenshot, the MySQL container is restarting over and over. Xibo can’t work with the MySQL container down, so you need to investigate why that is.

Please revert the change you made to the networking, and then get the logs for the MySQL container

docker logs xibodocker_cms-db_1

My guess would be that perhaps it was initially started without there being a config.env file in place, with a suitable password for MySQL added to it? If so, you’ll need to completely remove the MySQL container and start over to get that working again. The following assumes this is a new install. If you do this on an install with data in it, you will loose that data

docker-compose down
rm -r shared/db
docker-compose up -d