Cannot upload some files

I have installed xibo on a ubuntu server and running fine. but when i tried to upload a flash (swf) file it gives me an error saying " image require minimum width". The swf file is a count down timer which i have made using flash.
the dimension of swf file is

width = 240px
height = 568px

what might be the problem.

here i have attached a screenshot too.

i tried to tweak php.ini files but i can find any option for mini file size or anything like that.

Thank you.

Can you confirm what CMS version you are using?

If you can send me a copy of the swf file via private message, I would be happy to test it for you.

Many Thanks.

Thank you for the reply

my CMS version is Version 1.8.9

once again thank you for the kind help

Thank you for sending the swf file. I have uploaded it successfully to my media library and created a layout. The file appears to be working fine, I did not receive any error messages during the process.

Can you confirm the environment you are using? Are you using docker or is this a custom setup? This will help to narrow down where the issue is coming from.

Please note that I am using version 1.8.10 of the CMS, I would strongly recommend upgrading your CMS to the latest version as this may resolve the issue.

I would also recommend Selecting the Report Fault option in your CMS and confirming that the CMS environment checks are all passed. If you receive a message stating that not all checks were passed, select the Show Environment Checks option and let me know which checks failed.

Clicking Next in the Report Fault option will also give you the option to turn on Debugging. I would recommend turning this option on, attempting to import the file again, and checking the logs for errors in the Logs option on your CMS. If you can then pass on any error logs you receive, I can look into the issue further.

Many Thanks.

No i am using a custom setup. At first i tried to install the cms version 1.8.10 but i cannot install it due to an error which i have previously posted in another topic(Need Help to install Xibo on ubuntu). So i install 1.8.9 which install smoothly.

I check with the report Fault and all are passes and also i have enable debugging option and duplicate the error and collect the logs.

and here is what i found in the log as a fault

|3848|a37f3b3|8/15/2018 23:07|WEB|/fault/collect|GET|Loading 1. All Objects = 0||DEBUG|
|3849|a37f3b3|8/15/2018 23:07|WEB|/fault/collect|GET|Install Fonts called with options: {"invalidateCache":false}||DEBUG|
|3850|a37f3b3|8/15/2018 23:07|WEB|/fault/collect|GET|CMS font CSS returned from Cache.||DEBUG|

Thank you.

Thank you for sending me the logs and for confirming the Environment checks.

I have taken a look at the logs and cannot see any errors relating to the swf file. Can you confirm that you did try to upload the swf file again, after you enabled debugging? If you could try to upload the file again with debugging enabled, but perhaps take note of the time that you did this, it will help to narrow down where the issue is.

Can you confirm whether you are having trouble uploading any other files to your library? If so, please let me know. can you also confirm if you have been able to upload any other swf files successfully?

The error “Image requires a minimum width”, is a PHP upload error. This suggests that the issue may be with your PHP configuration. I would recommend double checking your PHP configuration, to make sure all of the settings and parameters are correct.

I’m sorry to hear that you have had issues installing the 1.8.10 CMS. Just as a consideration, I would recommend a Docker installation. You may find the installation process is a little simpler. I’ve included a link to the installation page in case you would consider trying it:

https://xibo.org.uk/manual/en/install_docker_linux.html

Many Thanks.

i am using xibo 1.7.10 and i have the same error. personal server…nginx with mariadb 4.8.3

I would first recommend upgrading your CMS to the Latest version, which is currently 1.8.11.

If the issue persists after the upgrade, I would recommend selecting the Report Fault option in your CMS, following the steps and Turning on Debugging when prompted. Continue following the steps and click the open a new window option. In the new window, attempt to upload the file again. Once the error has been generated, close the new window and continue with the Report Fault steps. Collect and Save data at the end to generate a report.

Once you have the report, I would recommend looking through to locate any errors. you are welcome to post those errors so I can look at the issue for you.

Many Thanks.

file upload not allowing me to upload txt file

troubleshootXIBO1.7.10.pdf (185.0 KB)

there you go…log file

Thank you for the Log. Can you confirm what file type you tried to upload whilst you were creating this log?

Many Thanks.

a flash file (.swf). i have tried many times, still not working

i am going to do a further investigation into this issue. I installed xibo 1.7.9 on my NGINX server with ubuntu 18.04, php5.6-fpm, MARIADB ( * Server version: 10.3.11-MariaDB-1:10.3.11+maria~bionic-log - mariadb.org binary distribution) …surprisingly, i get the same error when i try to upload a flash file (.swf). I have xibo 1.7.9 on a shared hosting server and i am able to upload that same .swf file there in my layouts…I am starting to suspect ubuntu 18 and how it deals with PHP and DB installation / setup…

i may be wrong…if you found out the cause, let me know…i am going to try ubuntu 16.04 with MySQL-server as DB and same php5.6-fpm and see if i will be able to upload flash files without that error “Image requires a minimum width”

very annoyed, I was prepared to move my xibo from shared hosting to my own server to avoid paying for hosting…my hosting is up for renewal in 7 days…lord jesus

any solution to this swf upload issue please?

Same problem here.
Running Xibo 2.1.0 with Docker on Ubuntu 16.04.6 LTS.
The system passes all CMS environment checks.

Xibo Log: https://paste.ee/p/5p4zi