Cannot upload media from timeline, works from library

Hi there,

We have just updated our CMS from 1.7.9 to 1.8.2. Everything has upgraded ok, however we have a slight issue with uploading content from the layout/edit timeline screen. Uploading content from the Library (Media) screen works perfectly. I am doing the following:

Layouts -> Click Design on any layout -> Edit Timeline (on any region) -> Add Media (ppt) -> Add Files -> Browse and select file, click open.

This then does not update the modal with the list of files and progress bars that usually appear. However if I hover over the Add files button the tool tip shows the selected file.

If you then try and continue and click upload files we get a (Sorry we could not find that page. Please check your URL or press back in your browser) error.

Any info would be greatly appreciated and if you need any more information please let me know.


Please can you tell us a bit more about your environment? Docker or not? If not Docker, what is the setup?

Sounds like either you have some script cached in your browser (if so try clearing your browser cache) or perhaps your rewrite rules aren’t setup correctly on your webserver.

Hi Alex,

Thanks for the reply. Its a standard install on Centos 6.9 that we have upgraded, its not a docker instance.

I have tried clearing my Cache, tried a different browser IE, usually use Chrome and tried on another computer. So looks like its a server issue. However the upgrade passed all the pre-requisites and it works in the Library :confused:


Do you have “web” in the URL you’re using to access the CMS?

No we go straight to

CMS is in /var/www/html/xibo

with the document root set to /var/www/html/xibo/web

Are you able to do that for us with Chrome developer tools open, on the “Network” tab and see if any errors are generated there please?

When loading any page in the CMS there are no errors/warnings in the Chrome console window.

Network panel for page url/layout/designer/90 shows: 106 requests | 103KB transferred | DOMContentLoaded: 814ms | Load 833ms

Looking at the log:

PHP logs shows no errrors/warning.
Xibo logs shows no errrors/warning, and have increased the logging to Debug.

Is it worth a re-download of the CMS files?

We released a hotfix of the 1.8.2 release on the 27th June (1 day after the initial release) which solved this issue - details were added to the release page:

The PR that fixed it is here.

I am not sure how you would have got the old files, unless you upgraded on release day?

Hi Dan,

Thanks for that. I downloaded the CMS files a while ago, however never got round to doing the update till last week. And with the version not changing I did not re-download files.

It looks as though I have been the very unlucky one that must have downloaded the the files between you releasing 1.8.2 and the hotfix.

Thanks both of you for your help.