Cannot upload large file - Unknown Error


#1

Hello
I am trying to upload a 1.08Gb MP4 file and I am getting an “Unknown Error”
My CMS version is 1.8.11 and is using Docker for Windows. I tried adding the command: --wait-timeout=300 to the docker-compose.yml, but that didn’t work.


Cannot upload large video file
#2

I’ve moved this to a new topic as it’s a different error to the one you posted in response to.

Most likely here is that you are out of disk space, either on the host machine, or in the Docker VM running in HyperV. Check on those two possibilities first.


#3

Hello Alex

I checked the physical box and it has lots of space. I am using the Docker Toolbox version. So it is using VirtualBox for the VM. Based on the screen shot do you think I need to add space to the VM?


#4

if you are using nginx as web server, try and add client_max_body_size 200m; somewhere in your default server block …mine is put here:
location / {
# First attempt to serve request as file, then
# as directory, then fall back to displaying a 404.
try_files $uri $uri/ =404;
}
client_max_body_size 200m;
# pass PHP scripts to FastCGI server
#
try that code and restart nginx then try the upload again


#5

df -h will give you human readable output, but that looks like 8GB ish free to me, so that doesn’t seem to be the problem.

Do you get the error when the upload is still in progress, or after that?


#6

It gets to 100%, then it sits there for a while and thinks about it. After that I get the unknown error.
I connected to my server and I found the video file in the Temp folder. “C:\Users\xibo\shared\cms\library\temp”.


#7

Perhaps a timeout then. Have you tried increasing the PHP maximum execution time?

It’s a setting in config.env

CMS_PHP_MAX_EXECUTION_TIME=900

then restart the containers.


#8

I did a docker-compose stop
I changed the CMS_PHP_MAX_EXECUTION_TIME=900
Then I started docker and tried to upload the file.
Still getting unknown error.

Should I have done a docker-compose down instead?


#9

I think stop/start would apply that but I’d down/up to be sure that it has applied.

If the file is inside the temp directory then it would seem that it got uploaded OK as its only moved there after the upload completes.

If you continue to get the issue, then you need to run the Report Fault wizard and do the upload again, and then gather the data from that after the error has been replicated and see what was logged from our side.

I know the container works with uploads up to just less than 4GB as I’ve tested it myself, so it’s likely to be a speed issue somewhere I suspect causing a timeout.


#10

I will try that when I get a chance. For now I have found a work around. I used Handbreak for compress the file and got it down to 250Mb. Then I was able to upload the video with no problem.


#11

any success? or you are still struggling? let’s hear from you


#12

Hi!
did you check your database file limit?


#13

I have not tried again, I haven’t had time.


#14

Is the database file limit in the docker-compose.yml?
I have tried adding the "command --wait-timeout=300.
I have tried setting the CMS_PHP_MAX_EXECUTION_TIME=900.


#15

The database file limit is in the PHP file, you should check that.