Cannot register an old display against this CMS

We experienced the same issue as in this thread: Docker for Windows: CMS is reset when I restart the host server

I have set up the CMS again - before I read this post.

Now when trying to connect a display that was already connected to the last CMS on this server I get the message:
“You cannot register an old display against this CMS.”

What can I do to get around this please? I reinstalled the app and I tried changing the hardware key but neither worked.


Hello SprinklesGelato,

did you tried to change the uniqe Display ID?
I had a similar problem under 1.7.9 because the Display ID was (however) the same.

This may could solve your problem.

HI Danrun,

Where do you change the Display ID? I changed the display name and the Hardware Key…neither of those worked.

I am going to try setting up a completely new display and come back to this one!

Install the Xibo Client.
After installation the “Player Options” program should be open.
Open the register “Advanced” and edit the Display ID.

I have tried doing this - on the Android version it’s called Harware Key. Unfortunately it didn’t work.

I’ve just taken a brand new device out of the packet and I’m getting the same error!

What Xibo for Android version have you installed on those devices?

I assume you can reach the CMS address on your android device in the android’s web browser?

A screenshot presenting the issue could be helpful as well.

Hi Peter,

We’re using ‘latest’ - we’re using a resell account - Sprinkles TV and I set it to download the latest version.

The error shows as below:

I have logged into the CMS from the web browser on the device and it’s perfectly fine.

Would you recommend that I change the version to 1.8, redownload the apk and see if that works?

If it’s set to latest then it’s probably 1.8R102, even if it’s 1.7R64 (as long as it’s atleast R58) it should be fine (although 1.8R102 would be recommended for 1.8.1 CMS) - Unfortunately I can’t see the version from your screenshot (it’s a bit higher on the status window).

Hi - I’ve managed to sort it out - I rebuilt the white label apk and it’s up and running!

Thanks for the help!