Cannot get xibo player connected to CMS

Greetings,

I’m having some issues when trying to connect Xibo Player 1.8.3 for Windows. I set my server address (http://serverip:8080), my key, and the library folder. When I hit the save button, it says connecting to the CMS, and after a short while I get “Unable to connect to remote server”. I’d like to point that my organization’s got about 110 branches, with the same standard network and firewall configurations and I’ve got it working fine in many of them. But I currently get this problem in 4 or 5 of them. Windows firewall is always disabled due to our external firewall.

Thanks in advance.

Can you navigate to the CMS address in the web browser on the PC with Xibo player?

Is the CMS accessible via http and is the Force HTTPS is disabled in settings?

In 1.8 series, all you should need is to have open ports 80 (http) 443 (https) and XMR port (default is 9505).

CMS is accessible (haven’t tried on the PC with Xibo Player) via http and Force HTTPS is disabled.
I’m gonna test it on the PC with Xibo player within 2 hours and then I get it back to you.
All the mentioned ports are open.

So, I just tried to access my CMS from the PC with Xibo Player and I couldn’t. I couldn’t even get a ping response. I guess the problem is some routing in my network. I’m gonna check the routes.

Now I can ping both my Xibo Server and my CMS address from the pc with xibo player installed. But I still get the same error. Any ideas?

If you can access the CMS address via browser on the PC with Xibo player, then I’d expect the player to connect to the CMS as well - all it really needs is 80/443 (http/https) and 9505 (XMR default port, unless you’re using custom ports then adjust for it).

I assume the CMS is in 1.8 series as well, could you please specify the version of it and if it’s docker or manual installation please?

The CMS version is 1.8.5, manual installation.

Somehow I got it working now. Instead of using my public server IP, I set my local server IP and that did the trick.