Cannot "edit" any display

Hi all,

i just added a new display and wanted to authorize it.
When clicking on “edit” i get the following Application Message:

“A two digit hour could not be found Data missing”

My Dates in the settings>regional is set to default.

When i added my test display this morning, everything worked fine.
I din’t change anything.

CMS: 1.8.1 (latest)
Player: 1.8.1 (latest)

Thanks for any help

It does not seem to be an issue in our cloud or my local CMS (1.8.1).

Could you navigate to the Display Settings -> Edit display profile assigned to your device
make sure that Download start/end windows are correctly set and click save,

After that see if you can edit the display.

If not you can change the start/end download window to let’s say 00:15 - 23:55 and save then try to edit - if it’s fine then change the values back to 00:00 and 00:00.

Hi Peter,

thanks for the quick response and the solution.
The fields have been empty so i set it to 00:00 and 00:00 and everything works fine again.


Empty? That’s rather odd.

Could you please confirm for me what installation is it? (docker or custom?)

Also was it an update or fresh 1.8.1 installation?

In any case, I’m glad that you were able to fix this issue.

It’s a custom and fresh installation of 1.8.1.


I met the same problem, and I can’t authorize my display.

Does anyone have any solution to this?

CMS: 1.8.1 (latest)
Player: 1.8.1 (latest)


Could you navigate to Display settings page -> edit display profile assigned to your displays then make sure they aren’t empty (what was the case with OP) and save it.

If that does not fix it, change the download time to something else than 00:00 | 00:00 and save it -> make sure you can edit displays -> change the download window back to 00:00 | 00:00

Hi Peter,

I have tried this method, but it doesn’t work.

If it’s set to different values that 00:00 does the edit display work then?

Could you please enable CMS debugging (report fault page) navigate to logs page -> recreate the problem in the new tab (ie try to edit the display) -> see what error does it show there?

Hi Peter,

I have set to different values many times, but it still doesn’t work. I think that’s because the display didn’t be authorized. And I checked the logs page, it didn’t show any error about this problem.

If you change the download window and perhaps upload window (if that’s android profile) to something else than 00:00 and save, is it still displaying ‘data missing’ on Display edit?

If so, please go through Report Fault wizard on Report Fault page (enable debugging, recreate the issue, check/download logs).

There must be something about it in the logs, especially with debugging enabled, which hopefully will provide us with more details about your problem.

Hi Peter,

Thanks for your help!

Finally we found the cause. We rebuilt CMS in PHP 5.6 and it runs OK now.