Bug : Owner doesn't update in the Layout table


There is a bug when you change the owner of an layout.

Permissions, the owner column update but you cannot use the “owner” dropdown on the top.

I tried to clear the cache and use another but the problem is still here.

I find it really weird, and we tried on a fresh server.

I think I can see the problem, I’ll create a bug report for it.

Thank you for bringing this to our attention.

But there is more…

When someone try to copy something whose owner has changed, then the copy has the first owner as its owner.

I’ll try to fix the database but there is a fix where you export/import I think.

If I found the solution, do you want me to write it here ?

The “layout” table is not updated when you change the owner, it’s a really simple fix to do :wink:

I updated the owner and now it works !

FIX : UPDATE layout SET userID=3 WHERE userID=4;

Yes, the user / owner id is not correctly changed upon request that is the problem.

I appreciate that you can manually change that in db, that’s always good (well as long as you know what you’re changing in db), but the bug stays we will look into that, so when you change the owner in web ui it should also correctly save the owner id, which for some reason is not happening at the moment.

Of course, I was just helping if someone has this kind of problem is the near futur (and if I don’t remember how to fix it).

Thanks for your help !