Black screen with mouse

So I have spent the last couple of days learning how to set up and use Xibo. Got the CMS up and running fine on an Ubuntu machine, and most of the client features working fine on a Windows 10 x32 machine. I only want to use Xibo as a screensaver, so I changed the Display ID in the screensaver and registered it on the CMS… All of the layouts that I have made show up fine, both on preview and the actual screensaver, the issue being that when I move my mouse to exit the screensaver, it sends me to a black screen with nothing but the mouse to use. I can get out of this screen using CTRL+ALT+DEL, but this is a bit of an inconvenience if the user has to do this every time the screensaver kicks in. I have tried the screensavers that come installed with windows and they work fine. Any suggestions?

Thanks in advance!

What player version are you using please?

When you open Windows Task Manager when the screen is black do you see any Xibo processes running?

My player version is 1.8.3.

When I hit CTRL+ALT+DEL, the black screen disappears and the mini menu pops up (Lock, switch user, sign out, change password and task manager), when I hit cancel, the desktop is back to normal, no black screen. If I open up task manager, I can not find any xibo processes running.

Done the exact same thing on a couple of Windows 7 x64 machines running the same player version today… no problem at all. So I guess this is a Windows 10 issue

Apparently there are some issues with black screen after screensaver on W10 after anniversary update, there are couple of different solutions for it which you could search for and try.

I did not encounter such problems, therefore I can’t really tell what exactly could be causing it.

Perhaps check all the drivers, gpu drivers specifically, perhaps double check power options, sleep, hibernate etc to ensure that it’s not some option that got enabled after the Windows update (which they tend to do after bigger updates).

Will be sure to check those tomorrow. Thanks for yor help :+1:

I’ve had a look at drivers and power options… they seemed to be okay. I tried xibo screensaver on a completely different Windows 10 machine, and I still get the black screen when I try to exit the screensaver. This other machine also has an older version of Windows 10. I must be doing something wrong… But I have no idea where to look. Works on every Windows 7 machine I try, just not Windows 10.

Still haven’t managed to figure out what I am not doing right yet… One thing that is a little interesting is that I can still bring up xibo information by pressing the “i” key. The information window is the only thing that will show over the black screen. Other Windows screensavers work fine.

Solved the issue by getting xibo.scr to put all of its contents on a folder on the desktop… No more black screen with mouse after exiting the screensaver. This also fixed another issue that I was having on Windows 7, where the screensaver would only run once and not again after exiting it.

Upgraded a machine to Windows 10 and tried putting xibo screensaver on it… Same problem as before (black screen with mouse), but this time, nothing seems to be fixing the issue, even what originally worked for me (dumping all contents on the desktop). I have no idea what could be causing this.

I downgraded the machine back to Windows 7 and now the screensaver only runs once and then never again… uhg

edit: Just discovered something by accident…

It turns out the xibo process doesn’t terminate until ctrl+alt+del is pressed. Once that sequence is pressed, the process is killed and the screensaver works after the timeout. So I’m starting to think that this is what’s causing windows 10 to display the black screen with mouse until ctrl+alt+del is pressed - the process must still be running, but crashes in a different way to what it does in Windows 7… the problem is exactly the same as what’s descried in this post: Xibo screensaver ONE-TIME-ONLY behavior - Sadly no solution though

You are not alone. I am also experiencing the same issue. My screensaver is activating just fine but like you, when you wiggle mouse or touch the keyboard, the screensaver goes black and only the mouse icon shows. Alt+Ctrl+Del closes the screensaver while also taking you the Task screen… no bueno.

  • Both Client and Server are running 1.8.2 (and I’ve also tried current 1.8.12 Client.)

  • I have installed the Xibo working directory in the C: root drive.

  • Computers are running Windows 10 Professional, several on domain; several off. Most x64, one x32.

Two items of note:

  • A legacy client install running version 1.7.8 has a screensaver that works just fine. It is fully updated with the latest W10 updates. But I am not successful in installing 1.7.8 on a new machine today and having it behave the way it should.

  • One thing I’d like to note is that my Windows screensavers are running embedded content. Webpages. Exclusively. Is it possible the embedded content is causing the issue? I dunno… but I thought it was worth mentioning, in case OP is running similar content… maybe it’s related to IE…

edit: I’ll happily offer one of my machines up for you to investigate the matter. I know you’ve noted your test machines are not experiencing the issue… so if seeing it live helps, hit me up and we can make arrangements.

I might give a 1.7.X client version a try.

Update: Installed 1.7.8 on Windows 10 Education and it is working fine… Will test this on a machine that I know doesn’t work.

Update 2: Version 1.7.8 is working perfectly on the one machine I couldn’t get xibo screensaver working on… Was this really all that I had to do? Uhg!!

Sorry that you are having trouble with the screensaver mode on Xibo for Windows 1.8. A bug report was created and is still being investigated, I have provided a link below:

Thakn you also for confirming that 1.7.8 does not have the same issue as 1.8, I hope this provides a suitable alternative whilst we fix this issue.

Many Thanks.

Really glad to hear my input could help you out. Hopefully it points the Staff in the direction for a fix! :smiley:

Thank you for your reply Dan. Didn’t realise a bug report had already been made :slight_smile:

The screensaver has always been quite strange. I have another Windows 10 box that has been running xibo screensaver smoothly for half a year now… And I think that the version on that is 1.8.X

Very strange. Wouldn’t have thought to go as low of a version if you didn’t mention it, thanks a million!

I’m also experiencing this exact issue.
Only Ctrl+Alt+Del kills the process, but seems to kill it instantly.

Windows 10 Education 1803
Dell PC with Radeon R7 250 GPU and latest driver
1.8.12 Client and 1.8.12 local CMS
Dell monitor at 1920x1200 (layouts are set up for this resolution correctly)

I can also confirm that 1.7.8 doesn’t show this issue but I’m tending toward using 1.8.12 to support some of the newer features.

Otherwise, the software on-board is minimal (just added firefox), system power settings are set for highest performance and all sleep settings are turned off. This happens with simple, single region, single image layouts so I don’t believe its related to any special content.

I’ve got same issue with xibo CMS 2.0.0 and windows player 2.0.0
I’m trying windows player 1.7.8

Is this working for you (cms: 2.0.0 & Player 1.7.8)? was thinking about doing a cms upgrade but am a bit scared that I’ll break everything again.