Black Client Screen


after some days (1-3) my client xibo screens turns black and no content (only JPEGs) is shown. The status is:

Changing the layout or closing the app does not help. Only force stop the app and restart the app helped and the content was displayed again. The CMS server is online and all other players work fine.

Minix Z64 Andoird, Client android 1.8-104

Any suggestions? Thanks… Yours Mark

There are 50(!) concurrent failed XMDS connections, which means player tried to reach the CMS 50 times (it tries that each collection interval) and failed every single time.

There are also over 709k (!) stats ready to be send, that’s a really big number of statistics records.

That implies there is a serious connection problem between the CMS and the player, be it something is blocking it (misconfigured proxy, firewall), internet is down on the device.

I assume the display is authorised in the CMS itself? If so it is definitely connection issue, your player simply can’t reach your CMS for an extended period of time.


Yes it is authorised. May be, should I switch of statistics/logs oder extend the collection time from 5 minutes to once per day?

First of all you need to look into the reason why the player has such problems connecting to the CMS.

You can switch off the stats, but that’s not the main problem, collection interval can be increased, but again that’s not the main problem, the problem is that display can’t reach your CMS for an extended period of time.

I think the problems started when upgrading the player from 1.8-103 to 1.8-104. I have players with no connection to internet at all and they do not show any problems running the 1.8-103 Version.

This is the second player showing black screens after a while after upgrading. Before everything worked finde.

Now i switched off stats and screenshots, but same problem again. Xibo only works again when i force stopping the app in the android app setting and start xibo again.

If you open the browser on the device (while leaving Xibo running), are you able to connect to the CMS webpage correctly?

Yes it is working correctly!

What is the CMS version please? How is it installed?

CMS Version 1.8.7 and Docker Installation.