Background image compression?

Hello Community,

I’ve noticed that the Xibo Client (Windows 7, IE11, Version 1.8.0) doesn’t use the same background-image file as I have uploaded in the CMS (1.8.0). I’ve saved my background with the highest quality I could find in Photoshop; there is no different between the JPG and PNG quality anymore. But at the Xibo Player it looks like a compressed JPG:

(zoomed cut of the background-image)

The cache-folder of the Client does include two files: the original JPG with good quality (the file I’ve uploaded in the CMS) and one JPG with the “bad” compressed quality (in “background”-folder"). The Client has got a 1920x1080 resolution, the JPG file does also have the same resolution.

I hope I’ve described the “problem” well. On a Full-HD-Display, the background doesn’t look very well with this “JPG artifacts”. Is there any solution to show the same background image file as I’ve uploaded in the CMS?


That’s rather odd, the background image you assign in CMS should be downloaded by the player and then displayed, I’m not certain why your player has 2 ‘versions’ of that file.

Could you sent me your good quality .jpg so we test it here locally please?
(send it to my via private message.)

1 Like

Hello Peter,

the background isn’t very secret so I post it here now.!AIlBROjUyGeulBA&cid=F988E05A732A9ADF&id=F988E05A732A9ADF!413&parId=root&o=OneUp

I must correct myself: it’s just 1366x768, not Full-HD. I’ve already created a new resoultion in the CMS which is set in the layout settings, so that’s not the problem, I think…

Thank you!

The player receives the file as you uploaded it, but then does create a copy of the file at the player resolution. It will attempt to create a JPG at 100% quality.

It does this regardless of whether the existing file is exactly the right size or not - perhaps that could be improved.

That being said, we’ve not had this reported before, so I wonder if there is something specific about your image causing an issue for the encoder. Maybe a dpi setting or colour pallet?

1 Like

Thank you for your effort! I’ll check out if there’s anything special with this image. My last Xibo Version before 1.8 was 1.6.0, I can’t remember if there was this isssue too.

Strange fact: when I use PNG (I know, not recommended for the Windows-Player) - i’ve got the same issue…

If you grab one of the backgrounds from the layout exchange, do you get the same issue?

1 Like

I’ve just tested the “4 regions, 16:9 blue” on a 1920 x 1080 Screen - the same issue. The region-borders are not as sharp as in the original file (artifacts) - there’s again a lower quality JPG in the Library\backgrounds folder on the client which seemed to be displayed in the Xibo Player…

Now that is strange indeed - those backgrounds have always been fine (for many years in fact). @Peter can you test one and the OP’s background to see if we can repeat the issue.

1 Like

I have 1920x1080 resolution here,

Jan’s image:

4 regions, 16:9 blue:

In both cases background image looks good on 24’’ 1920x1080 monitor.

1 Like

So that menas that your file (4 regions, 16:9 blue) in player library\backgrounds doesn’t look like this (greatly enlarged)?

The original file:

Of course there isn’t such a great loss of quality as it is with my background JPG, but it will be interesting if we have two different results with the same JPG file - and why they are different to the original JPG.

Maybe there’s something wrong in my environment - the Xibo Player is installed on a Samsung SyncMaster 460DXn with Windows 7 Embedded (IE11)…

Hello All,
I came here looking for an answer and didn’t find an exact one, but realizing that this isn’t normal behavior, I stumbled upon something that worked in my case. For whatever reason, the signage players I installed had the windows “increase text size” set to 125%. I’m not sure how this happened as I don’t remember personally setting this. When I set that back to 100%, everything cleared up fine. This option is accessed on Windows 10 by right clicking the desktop and selecting Display Settings.

I however did not have the duplicate files made.

Hope this helps someone.

1 Like

Thank you. Unfortunately, my “increase text size” was already set to 100%, so that’s not the problem.

I’ve noticed that too, and also on Android clients, not only Windows.
I would suggest to check for the resolution before resizing, if the resolution matches the requested size, no need to resize anymore. That would also save resources.

I have the same issue. Has a solution been found yet?

I’m not sure if there was an issue here, when I tested it over a year ago it seemed fine.

You’re welcome to send me your layouts or in fact just the source background files that you use via private message and I will take a look.

1 Like

Thanks for getting back at me this fast. I can upload it here as well. Original file:

I’ve already tried changing the extension and the number of pixels but can’t find what’s wrong.

That’s a 3826x1906 file at least the one uploaded here, which does seem like any usual resolution.

Is that the actual resolution of the source file you’re using?
What’s the resolution of your layout that has this file assigned as a background image?

It is the actual resolution of the source file. The resolution of the layout is 1080p HD landscape.