Access denied for user CMS

I’m setting up a new installation of Xibo, and having trouble getting to the initial login prompt. My installation is on Windows 10 64bit using Docker. My install directory is c:\xibo\xibo0docker-1.8.11

The error I am getting is:

Fatal Error - sorry this shouldn’t happen. SQLSTATE[HY000] [1045] Access denied for user ‘cms’@‘’ (using password: NO)

I have confirmed there is a password in the config.env file, and it was there before I started Docker. The password was generated from, as per the instructions. Per other support articles, I have tried these commands without success:

docker-compose down
rm -r shared/db
docker-compose up -d

This is the output of the docker ps command:

PS C:\xibo\xibo-docker-1.8.11> docker ps
5d2565cbcf2b xibosignage/xibo-cms:release-1.8.11 “/” 17 minutes ago Up 17 minutes>80/tcp xibo-docker-1811_cms-web_1
0c159c9ea70d mysql:5.6 “docker-entrypoint.s…” 17 minutes ago Up 17 minutes 3306/tcp xibo-docker-1811_cms-db_1
cebe7e76be31 xibosignage/xibo-xmr:release-0.7 “/” 17 minutes ago Up 17 minutes>9505/tcp, 50001/tcp xibo-docker-1811_cms-xmr_1

I’m sure I’ve missed something trivial and this is a noob error, but help getting this resolved would be much appreciated!

Update - I changed the password to something simpler, and now have access to the logon prompt. Suggests maybe an issue with the install documentation or the compatibility of complex passwords? Note, my password did not have special characters.

Without knowing what you put in there it’s hard to say, but I believe the documentation recommends 20 characters upper and lower case alpha numeric, and that definitely works, and provides more than adequate complexity for a service which isn’t exposed to the local network.

Thanks Alex,

I tried two different passwords from (created exactly as per the documentation), and neither worked:

Switching to a shorter, simpler password worked immediately.

I suspect you may have missed removing the data files between attempts.

Once you try without a password in config.env then nothing you do will work until you delete the data files and start over. MySQL’s container only reads that parameter in once on the very first time the container starts when there is no data.

If the password wasn’t read in correctly, the error would say “using password: YES” but it says “NO” which means the field in config.env was empty at the time.

I tried two methods: 1 using the rm -r shared/db command, and another using that command in conjunction with manually deleting the Shared folder. I used one of those methods when I changed password to the simpler one.

I had one of those two passwords in config,env when I first started the container, so I agree the ‘using password: No’ is an unexpected response.