1.8-rc1 Custom Fonts

I can’t for the life of me get a custom font to work in RC1.

I uploaded the font to the media Library where it appeared to install. The widget text editor shows the font as available, but doesn’t actually display it correctly. T

I find that the font.css file in the Library isn’t updated, but there is a folder withing the Library called ‘temp’ which contains the uploaded font, as well as the created font.css - however, this file is missing the path to the font. Adding the path does nothing.

This CSS file in the temp folder displays as:
@font-face {
font-family: ‘clan-book book’;
src: url(’’);

I’ve also tried rebuilding the fonts with no luck. I can send the font file if needed?

Can you delete the font from the library and then run through the Fault page please, reuploading the font again in the process?

You could also add the font file to the ZIP that gets downloaded, so we can try it here if we need to.


Strange - I tried uploading the same font file to a Docker install and it worked just fine (on my Mac).
The problem install is on Windows running WAMP.

I’ll message you with the log files and a test font file I used.

1 Like

Hi Dan,

Did you get the log files?
Any ideas?


I’ve not any anything from you i’m afraid - perhaps you have dropbox or something similar you could pop them into?

Hi Dan, I sent you a private message from this platform? It contains the dropbox links to the files.


I received that now - thank you.

As a first test we uploaded the font on a local dev environment and it worked without issue - i suppose this stands to reason as it also worked for you via a Docker install.

The log you submitted does show the font being uploaded and contains all of the log messages I would expect for a successful upload. Including saving the updated fonts.css file to the library.

Can you please check that:

  • The contents of fonts.css in your library folder
  • Whether you get a new TTF file in the library folder after upload

Sorry I can’t isolated the issue with what you’ve provided so far.

Hi Dan,

As mentioned in the first post, the font and fonts.css file went into a ‘temp’ folder in the library and didn’t make it into the actual library itself for some reason. Unsure why.

I did some more playing around and found a way to manually fix it.

In MySQL (PHPMyAdmin), the row for the font in the Media table did not have a library filename set (e.g. 34.ttf - It was null).

By manually copying the font file into the library and adding the correct name in the MySQL row entry seemed to fix it.
I also had to manually update the fonts.css file with the file path, but suspect if used the fonts module to rebuilt, it would work correctly now it knows the correct file path.

Maybe it’s just a config issue on my end.


1 Like


I’d like to confirm the exactly same problem on my installation of Xibo 1.8 RC1.

The server is Windows 2012 and XAMP.

Everything seems to work fine but I have the same problem when installing any font.
The fonts.css is copied to library folder but also stays in temp. The contents lack file location.
The font file is left in temp and not copied to library.

Apache error.log shows no errors.


1 Like

Well this is definitely why it doesn’t work - what I don’t know is why it happens. My best guess is that something we did to enable concurrent file uploads is causing the file to finish uploading, the media record to get written to the DB - but the final move/save not to occur.

This has been reworked again for RC2 (as it wasn’t doing what we expected), so perhaps that would fix this issue.

Thank you dan for your response.
I will test it as soon as the RC2 is out. Can you give us some estimates when do you plan to make RC2 public?


Sometime around 22nd December - you can see what we have left to work on here

As soon as RC2 is out i’ll check this process and let you know if it is OK.
Thank you and keep up the good work.

I had a similar but slightly different problem:

  • Fonts would upload, work on a player, but wouldn’t show up in the fontcss file.

In my PHP settings I had disabled things like exec and system calls (and a host of other things). Apparently Xibo needs that to open/compile the list of fonts although there was never any error logged. Check your php.ini and make sure certain functions or classes are not disabled as a security feature of your WAMP stack.

It shouldn’t need exec, but it may well need other system calls.

These were the system calls that were blocked:


I don’t think it uses proc or curl to build the fonts.

Me either.

It did use a promise library in rc1, which we’ve removed in rc2. I wonder if that uses some system call I am not aware of. I think the best thing to do is have the OP retry once rc2 is available.

I have tested the problem on RC2 and it is still there but systembehaviour has changed.
Now the font file is left in temp but the fonts.css is not touched at all.
The system now detects the problem and gives the error message which is also logged:
2016-12-27 15:26 WEB POST ERROR /library Error uploading media: Problem moving uploaded file into the Library Folder
Other media such as pictures are uploaded fine.

I have tested Fonts module and when I try to rebuild fonts it generates fonts.css file in the temp folder but this file is not moved to main library folder.

Difficult to know what could be wrong here then - the error logged is shown when the application issues a rename command against the temporary file, to move it from the temp folder to the library.

Can you get us an audit log so we can trace the file name it is trying to use, etc.?

I have sent you the audit log.
This problem seems to affect only certain part of the system (for example images and videos are uploaded fine).
I have suspected directory permissions but they seem OK (and in such case the images wouldn’t upload either).

Maybe fonts module uses different function to move/rename files?