1.8 Alpha/R58 - Green MP4s

It seems that between the 1.8 alpha 2 and R58 we lost the ability to playback mp4 files correctly on some devices.

The main model of units we have that have been working excellent are showing this problem. Other hardware seems to be fine.

The files when played just show a green screen with shadows. They work fine with 1.7.5 and R57, so I am not sure what would have changed that would have any effect on them. We haven’t had the time to trace more (Like R58 on 1.7.5/1.7.6) down on this, but it is something we have noticed.

Update: Video Play Backs are fixed when enabling “Use a SurfaceView for Video Rendering?”. What does this do exactly? Will it cause any known problems?

Yeah it’s mentioned in the R58 release notes.

We’ve switched video playback to use Texture View by default which means no ugly black flash when changing videos within a layout. Unfortunately it seems some devices don’t like that for whatever reason.

There’s a patch for the 1.7.5 CMS linked in the release notes to turn TextureView off and Surface View back on (ie go back to R57 behaviour). If you’re running with a 1.8 CMS then I don’t think there’s a patch as it stands, so you’ll need to use R57 until there’s a CMS patch to change the Player setting.

Just to clarify, there is no patch, but this option should be there in 1.8alpha2.

In which case @cslaughter you can just change that setting in the Display Profile to use Surface View instead of Texture View for your affected devices.

1 Like

Worked just fine this way. Also thank you for the information Alex.

1 Like