1.8.1 Datasets dropping leading zeros

When adding data into datasets the leading zeros are removed.

I have tried both number and string. Still the cms removes the leading zeros, and treats everything like a number. This should not be the case if string is selected, really I think it should not be the case for number as well, especially if you are using the number value for a time string. (datetime option does not work for this)

Could you please show me how and where exactly the issue occur?

If you edit dataset column value to let’s say 0.123 does it cut the 0 from it?
Or does that happen later after the dataset data is displayed?

// It seems to work fine for me, that’s why I’m asking for more details.

If we bring up the dialog box to edit data and set “bgStart” and " bgFinish" as follows

Save the changes, it then is saved as

“000000” becomes “0”
“063000” becomes “63000”

It does this for both number and string. I would like to not do it for either, but certainly not for string. :slight_smile:

Interesting, I tried it with both string and number column data type and it does not cut anything:

@dan any ideas?

I am going for mysql version issue then…

I am using 5.7.18

Should had also noted it is a Docker install.

I know you guys are really busy. Has anyone had time to look into this? Is there anything I should try?