1.8.0-rc3 with Docker - Upgrade Issues from launcher to docker compose


I am currently running 1.8.0rc2 using docker. I am trying to upgrade to rc3 with docker compose.

I have read through the steps here, and when it says “Replace the contents of your Docker files with the new release archive for 1.8.0-rc3” I assume this means replace the xibo-docker-master folder with the new xibo-docker folder. My DATA_DIR is located at /opt/xibo, and I backed that up as well.

When I run docker-compose up after updating the MySQL password from my old launcher.env file, the install completes, but it doesn’t do an upgrade, it does a brand new install. I don’t see an option in the new config.env file for defining the DATA_DIR, so I assume the issue is that it doesn’t see my current MySQL DB, and that is why it fails at the step to check cms-version with “cms-version doesn’t exist - New install”

Do I need to stop the current Xibo, then move the DATA_DIR somewhere else?

Should I have placed the contents of the xibo-docker folder inside my existing xibo-docker-master folder?

Sorry that I am not understanding this process, I really hate to keep bothering you all, but the steps are not clear to me.

Thanks in advance.

It would be best to download the 1.8.0 docker and upgrade your CMS Instance to the release version
You can find all here http://xibo.org.uk/manual-tempel/en/release_notes_1.8.0.html

Please read carefully the ‘Changes to Docker’ section in that manual page.

I am already running 1.8.0rc2 using docker, why would I need to download 1.8.0? and I just asked about the change to docker section above. Those steps are not clear to me, and that is why I posted this.

As a side note - 1.8.0 is newer than 1.8.0-rc2

The issue you have is because using the old “launcher” method we were able to separate the location where you stored your data /opt/xibo and the launcher file.

We no longer support that from rc3 on ward as there isn’t any sensible way to do that with docker-compose (however the other benefits far outweigh this).

The key information is that the contents of the xibo-docker archive must be extracted into the same location as your data folder root - i.e. /opt/xibo

Ok, so I have figured it out by doing the following:

Dropped the files from the new xibo-docker folder into my existing /home/ubuntu/xibo-docker-master folder. This action is for step “Replace the contents of your Docker files with the new release archive for 1.8.0-rc3” That might be self-explanatory to most, but it wasn’t fully clear to me. Then I moved my shared folder from /opt/xibo to /home/ubuntu/xibo-docker-master/ and modified the config.env with the DB password as instructed. Then I ran docker-compose up and it is working great as an upgrade, and my data is all intact.

It might be best to add a note that if a user is running 1.8.0rc2 and has set a different DATA_DIR location, then they need to move the shared folder back inside the same folder as the docker compose files or the upgrade won’t work, and it will act as a new install.

Thank you, both for your time. I hope this post will help someone else when upgrading from rc2 with a different DATA_DIR location set.

Best regards,

@dan @Peter Guys, I am so sorry that I am so thick minded I didn’t notice you were telling me 1.8.0 was released LOL. I for some reason thought you were telling me to install 1.8.0-beta or something. Geez, back to get more coffee.

Well, how exciting, Xibo 1.8.0 is finally released! Congratulations to you all, I know this build has been a giant one!

Thanks again for all your hard work support us users. I truly appreciate it.

Best Regards,

1 Like