Xibo Win 11 player does not show layout from Docker CMS


I have Player version V4-R402.1

We have the CMS version Version 4.0.6 and I experiences some issue when starting the player in the windows client. See the attached image.

How do I continue?

Best regards Fredrik

It looks like your player is downloading some files from the CMS. Did you set up the XMR in the CMS?
Go to Administration > Settings > Display > XMR Public Address
Enter your CMS IP address here as per below

Then go to Administration > Display > Display Settings > Select Windows profile > Select Edit
Make sure you also set the XMR there too

Restart the player to see if it helps

On another hand, it seems like the Xibo Player for Windows have some bugs in Windows 11 Pro…
Mine does work for about an hour and then crashes. The Watchdog restarted it for another hour and crash.
The event viewer show was memory leak (we have 16GB RAM, Intel Core i5 9th Gen) and something about the video rendering…
You can check the event viewer for the log?


Thank´s for your reply. I will check it and return asap :slight_smile:


I have checked and I found alot of crashes in the eventwiever the player is showing this:

The Watch Dog:

I have set the tcp address for the XMR i CMS bu no good result?! :frowning:

The Xibo player for Windows is currently only support 32 bit, which means it can only use up to 3 MB of RAM from hardware regardless how much RAM your PC has. Therefore, media files such as image, video, PDF etc… should be kept as small as possible. For example, I used to have a photo which is high resolution, the size is 5.5MB and that will cause the xibo player crashes. I resize to under 1MB and it’s OK.
For video, it’s best to keep the resolution as max 1080p. The 4K will crash the player
And just to make sure, your layout must be “published” before it can be played. Also, you should set the default layout in the display too, in case you don’t set any “schedule”
Hope this help

Ok thank´s for the information. You must mean 3GB not 3 MB :wink:

My layout uses 1080p … and my test layout has just a clock!

In Xibo cms logs I got:

Unhandled Exception: UnobservedTaskException: Exception for a task was not caught, either due to waiting on task or accessing its exception property. For that reason, the finalizer thread threw the uncaught exception again.

The player information shows:

From the player information windows, I still think you have some issues with the communication between the player and the CMS as there is no files downloaded into the player PC

1/ First, try to remove the player (using the CMS) and re-add it again, using the "Xibo Display Options. When you add the player, use the CMS’s IP address and the secret key (found under Administrations > Settings > Configuration > CMS Secret key
2/ Wait for a few second and go to CMS, see if the xibo player populates in “Display > Display”. If so, authorize the player and then check the status in the row below it
3/ Go back to your Xibo Player, in the xibo player options, hit Connect again to see if it’s connected? If so, you can start play
4/ If you are in VLAN environment, make sure the player and the CMS are in the same VLAN or, at least be able to communicate (Firewalled, port routing, allow port 9505, 9696, etc…)
5/ If you switch to different accounts back and forth (like Admin and Users), you will need to reconfig the player using xibo player options, enter the CMS’s IP address, Secret key, etc… Xibo player doesn’t seem to remember these settings

Hope you get lucky this time


Some update:
I was playing with the XMR address and the player is connected now but no success yet :frowning:


I have wondering if there are som issue with the certificate between the server an the Player. You see I have another service which needs use of a certificate!

The player is recognized by the CMS bacause I can Authorize the player so the communication should work, does not it?

Not sure what’s actually your problem here…
Care to share your layouts so we can have a look what is/are in your layout?
Just to be sure, have you published your layouts? If a layout is in “draft”, it may not be displayed though…


The Layout I am testing with is named Test, see bellow:

It is clock as bellow:

As you can see the layout is Published :slightly_smiling_face:

First, maybe it is the way you setup the layout to be played then. Check and set the default layout:
Administration > Settings > Displays: Make sure you select the layout in the “Default layout” drop-down menu. This is to tell the player to play the layout if there is no campaign or schedule of playing.

What I did and it worked for me:
1/ Create layout(s)
2/ Create campaign(s), select type “Layout list”, select the layout(s) to add into the campaign
3/ Create a schedule that will play the campaign(s) that you created in step 2

Second, about networking:
I see that you are hosting your CMS via domain, tcp://appmt.order.se:9505, correct? If so, make sure you can access that domain from within (inside) of your network. Check the firewall status, hairpin loop, mDNS (in case of VLAN) and port forwarding (DNAT), etc… The point is to test if the Xibo player for Windows can communite with the domain where you host the CMS or not?

Good luck


Make a campaign did not work. Will look at the networking part later!

To make sure that the address is correct:
We have the cms in:

We have NGINX in the Linux server hosting the docker container for Xibo then we have a web page in another container and the server and have NGINX for handle the domain of appmt.order.se

I thinking if there are some issue of what address to use?

You can test your network by removing the existing display and re-add it again.

1/ Run Xibo Player Options, fill in the credential from your network and from the CMS, then click “Connect”. You will see the message per below:

2/ Go to CMS > Displays and authorize the pending request display. Then go back to Xibo Player Options, click “Connect” again. If successfully done, you will see the screen confirmation below:

Once you get this confirmation screen, you can click “Launch Player” to run the Xibo Player or, you can click “Exit” to quit the Xibo Player Options program. Then, run “Xibo Player” program

3/ The CMS address should be like this:

The port that it serves is 9505 so you must have this port forwarded to the CMS. I see your CMS address is https://appmt.order.se/xibo does not seem to follow this form

Sorry, typo on the number 3
there is no 9505 port as it is for XMR

Ok. My Settings of the file config.env:


NGINX config:

At last the container config of Xibo:

I hope this help :slight_smile:

Best regards Fredrik

In our environment, we host the CMS on a separated Ubuntu server dedicated for it only on a dedicated VLAN for it as well. Other servers such as Authentik and NGINX Proxy Manager/Traefik are on another server and located in different VLAN too.

I am not very familiar with your network environment and NGINX in general. But looking at your docker-compose.yml, I think there might be a problem with the “port” you use. In our case above, our port is:


  • 80:80

The is a loop-back IP address for the local machine, you might not to specify this.

The left 80 is the port you specify to access the Xibo CMS. You can change this port to whatever available port in your config. Also, the NGINX server will take port 80 and 443 so you most likely need to use other port than the default 80 if your NGINX and CMS are on the same server

The right 80 is the internal port that CMS will listen to. You can’t change this

In the end, the key point is, no matter where you host your CMS server, behind proxy or not, authenticated 2FA or not, you must be able to communicate it from where your Xibo Player installed

Good luck


I have change to port 8181 both in docker-container and the nging config. I have restarted nginx and reach the xibo cms now.

I can ping the linux server from my computer where I run the player and it work. As I understand I must be able to communicate with the specific container where Xibo cms is running, does not it?

Player must be able to communicate with CMS to update any changes that you make in the layouts/media
And congras that finally you can get it working!


The Player Information and Status looks like this:

But the Layout is showing!

I will install a VM with linux and test the cms.