Xibo Upgrade to 2.0.1 Database Migration


I upgraded my Xibo 2.0.0 to 2.0.1 on Windows Server 2016 with IIS 10 by following the steps as written here.
I replaced the Xibo files with the new files and restored my settings.php.

I can login to the Xibo Installation but when I access the /layout/view page I get following error:
DataTables warning: table id=layouts - Ajax error. For more information about this error, please see http://datatables.net/tn/7
I receive a similar error on other pages.

I thought this was because the database layout changed in version 2.0.1 so I tried to migrate the database by executing vendor\bin\phinx migrate -c phinx.php in the Xibo root directory. However, I received following error:
'vendor\bin\phinx' is not recognized as an internal or external command, operable program or batch file.

Is this error occuring because I did not migrate the database? If yes, what are the correct steps to do this on Windows?

Thank you for your help.

If you can’t support me with upgrade, can you at least tell me how the database schema changed, so I can try to migrate the database manually?


cd into your installation folder C:\PHP_FILES
Run this command:
php vendor\bin\phinx migrate -c phinx.php

The problem I see with your error is that you didn’t put “PHP” in the command

I did not run this command because it did not say so in the upgrade manual I linked to.
However, I tried to run it and it finishes without any output but the errors I see in the CMS still appear.

Okay, after researching I found this.
Apparently, the phinx file is a bash script. It is not a PHP file and is not supposed to be run with PHP.
For Windows, there is supposed to be a batch file. However, this file does not exist in my directory.

Please advise me in how to properly upgrade my installation.

I found this link to be helpful in migrating my database:


Hello Skidoo,
thank you for the link. I have followed the steps. The migration finished and the output stated it was successful. However, when I access my CMS I still get the same error.
The names of the database files in the Xibo database in my MySQL folder have not changed, in case that is supposed to happen.

I ran the migration as administrator, so I don’t think it’s a permission issue.

Does any one have an idea why this didn’t work for me?


Okay, I did some further digging. I compared the migration files from Xibo 2.0.1 to the migration files from 2.0.0 and they’re the same, so the database is not the cause of the error.

Next I tried following the link in the error message. I did the steps described in the Diagnosis section and found what is causing the error message (layouts, logs etc). Every time Xibo makes an Ajax request on one of the pages where I get error messages, it receives an HTML file with a 404 error code instead of the JSON it is supposed to receive.

However, I don’t know what the cause for the 404 error is and I don’t think I can figure this one out by myself. Any help with this error is appreciated.

Edit: nevermind, I figured it out after doing a Google search with regarding Ajax and Xibo upgrade. This solved it: Ajax request fails after 1.8.2 upgrade

Hello Llaura,

Have you been able to solve the issue ? When I run the batch file for windows, I only get “Link: …/robmorgan/phinx/bin/phinx”


sorry, I’m afraid I can’t help you with that. My issue is resolved and I don’t know what’causes your issue.

Tnx ! I’m struggling with the DB upgrade command phinx :wink:

I Found it :stuck_out_tongue:

the windows batch file is located deepx in the vendor/robmorgan subfolder … I ran it and the migration went without errors !