XIBO step by step Installation IIS 8.5 on WINDOWS SERVER 2012

When I navigate to localhost it redirects to localhost/install, but the page is mostly blank. All I see is a black bar at the top with Xibo Digital Signage on the tab.

Dear michael!
Thank you for the very informative and professional guide!
I have the same problem as lparetti9.
I also tried to install on xampp server and had the same result…
could you sugget what is the problem?

thank you very much!

This fixed my issue. Altering line 49 in the lib/Helper/Translate.php file:

1 Like

Fixed mine too.
Thank you!

With the help of this manual installation guide and a little hint here (Can find mcrypt in PHP 7) I managed to get Xibo CMS 1.8.11 running on Windows Server 2012 R2 with IIS 8.5.

The mcrypt is going to be dropped in 1.8.12 what I understood and have been reading on the Xibo CMS Github:

So far it seems to be working, in the coming days I’ll see if everything works fully fine and it all works well towards the screens as well. (Will post an update later on on this.)

could not open…why?

There is no space xmr error

Thanks but only one that just appear

Hello guys,
Is it possible to follow the same guide for windows 10 or 8 ?


is it possible to install the XMR as Windows-Service with nssm (no sucking Service Manager)?

Yes, of course
very easy

Thanks a lot, it works great :slight_smile:

Omg! thankyou so much for this amazing guide, i have been searching for this since 3 hrs now, it worked.

Better update installation for Xibo 2.0… presently the tutorial only work with Xibo 1.8

For 2.0 it’s the same.

It does not work! There will be error!

Hi dan i also get same issue as same as xMonty gets. Coppied the config.json with corrected format.

What can be the issue?

@bturcan – and you followed this process exactly: Upgrading to xibo v2, unable to do database migrations

My setup: Windows server 2016 with php7.1.1, VC14, NTS. I followed the instructions above but i only get the first line when i excute php xmr.phar.
xmr.INFO: Starting up - listening for CMS on tcp:// [] []

In eventviewer i find the following error:
PHP Fatal error: Uncaught Error: Class ‘ZMQContext’ not found in phar://C:/path/xibo/vendor/bin/xmr.phar/vendor/react/zmq/src/React/ZMQ/Context.php:15
Stack trace:
#0 phar://C:/path/xibo/vendor/bin/xmr.phar/index.php(60): React\ZMQ\Context->__construct(Object(React\EventLoop\StreamSelectLoop))
#1 C:\path\xibo\vendor\bin\xmr.phar(10): require(‘phar://C:/path…’)
#2 {main}
thrown in phar://C:/path/xibo/vendor/bin/xmr.phar/vendor/react/zmq/src/React/ZMQ/Context.php on line 15

Could someone help me out.

I’ve just finished my XIBO 2.2.2 installation on Windows Server 2019 with IIS 10.0, PHP 7.2.27 and MySQL 5.7.29.
One comment to your instructions. I had to set following parameter to 8192 to avoid ajax errors:
“Default Web Site-> Request Filtering - Maximum Query String (Bytes) to 4096”
Also MimeTypes .woff and woff2 were already in place.

1 Like