Xibo server on windows server2012r2


Can someone please tell me if i need to install asp.net any of the versions ?



It is not necessary, you need to put your website with Xibo running by PHP with FastCGI.
There are some other connections related to the maximum upload size and performance improvements, but it does need to be done on windows or linux in PHP

1 Like

I was able to set a standard for Xibo 1.8 on Windows with FastCGI, I am willing to give any support to the users.

Hello laercionit,
have you installed the xibo application on an iis webserver?

I try to install it on an iis but it’s very pain. After i have imported the rewrite rules of the .htaccess file into the web.config of the iss i am able to install the application. But now i have the problem, that i can’t login to it.

If i visit the website i see the login screen. When i insert the credentials and press the login button, i get the error Message “Sorry the form has expired. Please refresh.” With the network analytic Tool of the Firefox i can see, that the Request is into a loop.

Have you any ideas?
Thanks a lot (=

We would need to review all the permissions and their installation process.
I think it may be related to URL Rewrite, you installed this module without IIS.
Introduce an installation, need to import the .htaccess, follow my reference.

If you want we can try to solve it by teamviewer …

RewriteEngine On

#RewriteBase /xibo

# fix authorization header
RewriteCond %{HTTP:Authorization} .+
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

# requests for api authorize
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^.*/authorize/.*$
RewriteRule ^ api/authorize/index.php [QSA,L]

# requests that start with api go down to api/index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^.*/api/.*$
RewriteRule ^ api/index.php [QSA,L]

# install
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^.*/install/.*$
RewriteRule ^ install/index.php [QSA,L]

# maintenance
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^.*/maint/.*$
RewriteRule ^ maint/index.php [QSA,L]

# all others - i.e. web
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [QSA,L]

It looks like your web root is wrong (you have web in your URL, which you shouldn’t) and also url rewriting (you have .php in your url and shouldn’t).

Url rewriting should be solvable by using the config file in the manual: http://xibo.org.uk/manual-tempel/en/install_environment.html#url_rewriting

You will need to change your web root.

thanks for your replies. I have changed the Web-Root to *\Web and imported the .htaccess Rewrite Rules (over the iis importer) to the web.config

The URL looks now like this “http://xxx/login”. But the problem still exist :frowning:

I have also two screenshots in the attachment. The only difference i can see is the Statuscode at the moment the Client send the POST. But i’m not sure if thats the problem.

The status code being different is normal - the process has errored rather than redirected.

When you get to the login page, can you do a Shift F5 to make sure you have a new uncached copy of the page before trying to login?

You should also see that one of the POST parameters is a token - can you see that?

i have also cleaned the Webcache and something like that.
Yes, there is set a token in the parameters.


That username and password is blank is correct. I don’t typed in any credentials just to test the behavior of the form.

Did you remove the authorization directive, as I believe it is incompatible

I’m clutching at straws a bit here as I am not exactly sure what is happening at the moment.

Hey dan,
i think i have fixed the problem now :triumph::open_mouth:

What i have done is to create the webroot complete from the beginning. The difference this time was, that i choose the Webroot “xibo\web” and not “xibo” in the iis config. Than i imported the .htaccess RewriteRules over the iis importer.

There must be something wrong at the last installations this morning because of the wrong webroot and missing RewriteRules :o

Thank you very much @all :slight_smile:

In the attachment i want to share the iis settings if there are other persons with this problem.

1 Like

Great, i’m pleased you have it working.