Xibo Players not Showing Text, Tickers, Clock

Hi all,

I’m working through some issues with Xibo since an upgrade from 1.4.x to 1.7.4. My players are displaying images, backgrounds, embedded web, flash and HTML fine, but not tickers or text. Nothing appears for those regions at all. you can see from the screenshots below, my test layout has a number of regions (plain text, clock, embedded html, webpage, image, ticker), but in the second shot of the actual player, I see nothing for text, the clock or the ticker.

I don’t see any errors in the info windows on the display:

And the library folder on the client seems to have downloaded all the content properly, I can even open the .xlf file and see my ticker content:

As an Xibo user for about 5 years now, I can say I’ve never seen anything like this, and it’s totally baffling. I’ve enabled debug logging on the server and auditing on the displays. My troubleshoot.txt file is here. And the logging from the display in the screenshot is here, if that helps. Ignore any regional setting errors about en_AU, that’s been changed to en_US.

Any help I can get would be appreciated. I’m very close to having a working 1.7.4 system upgraded from my 1.4.x. The details of my setup are:

  • Xibo server 1.7.4 on CentOS 6.7 (migrated from old server Running OpenSUSE 11.x)

  • PHP 5.3.3-46

  • MySQL mysql-5.1.73-5

  • Apache 2.2.15-47

  • Players I’ve tried are 1.7.4 and 1.7.0 on Windows 7 and 8.1, plus the Android trial - same result with all.

Please Help!


I assume this is a new layout? (created on 1.7?). Does this layout looks fine in the CMS preview?

Did you perform upgrade from 1.4 -> 1.7 in one step?

Perhaps something went wrong during this upgrade, are you sure that you did everything as described for example here - 1.7.0 release notes I assume that you also did restart your webserver etc. ?

Looking at your player status window, there seems to be missing few quite important things, could you please try to click the ‘verify all’ on modules page and let players download stuff again?

There is for a few times error about requiredfiles, did you move your player local library? Perhaps it has some permissions issues now with access to that location? Could you check if that file is in the player local library?

It might be a good idea to share a screenshot of Android status window too if you can.

1 Like

Hi Peter,

Thanks very much for pointing me to the Modules > Verify All option. That pointed out a permissions problem with the Fonts module, which I fixed, and now the displays are working, both using my old layouts converted from 1.4.x, and my new ones.

That’s got my test upgrade complete. Now to to one on a production system! :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.