Xibo player not starting

Hello,
On the r4 release, when i run the player, it won’t start. But, it will output a error saying : [Main] [ImageGTK] Size should be positive. I checked the cms to see if any existing size was negative, and there was none. Does anyone know why it happens?

Same error here.
Tried with Ubuntu Desktop 18.04 and Xubuntu Desktop 18.04, same error.
The player starts (you can see it in the processes with ps aux | grep player but there is no display.
Thing to note, the player appears as soon as I click on a menu or make the Ubuntu dash opens.
Without doing any action (my box is unmanaged by humans, it starts at boot and it is plugged to a 55" screen with no mouse/keyboard), the player just dont display.

Here are my logs :

Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: [16:06:02.680] [2239] [debug]: [DBus] ScreenSaver is suspended: 1646031242
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: [16:06:02.680] [2239] [debug]: [DBus] ScreenSaver is suspended: 1646031242
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: [16:06:02.681] [2239] [info]: [XiboApp] http://127.0.0.1:1234/
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: [16:06:02.681] [2239] [info]: [XiboApp] http://127.0.0.1:1234/
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: [16:06:02.685] [2239] [error]: [WindowGtk] Fullscreen mode hasn't been activated
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: [16:06:02.685] [2239] [error]: [WindowGtk] Fullscreen mode hasn't been activated
Nov 25 16:06:02 xibo-zotac-test player[2239]: Failed to set text '<markup><span size="18446744073709551599"></span></markup>' from markup due to error parsing markup: Value of 'size' attribute on <span> tag on line 1 could not be parsed; should be an integer no more than 2147483647, or a string such as 'small', not '18446744073709551599'
Nov 25 16:06:02 xibo-zotac-test player[2239]: Failed to set text '<markup><span size="18446744073709551599"></span></markup>' from markup due to error parsing markup: Value of 'size' attribute on <span> tag on line 1 could not be parsed; should be an integer no more than 2147483647, or a string such as 'small', not '18446744073709551599'
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: [16:06:02.686] [2239] [error]: [XiboApp] Error while upadting settings: [WidgetGtk] Size should be non-negative
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: [16:06:02.686] [2239] [error]: [XiboApp] Error while upadting settings: [WidgetGtk] Size should be non-negative
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: [16:06:02.709] [2239] [error]: [Main] [WidgetGtk] Scale factor should be positive
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: [16:06:02.709] [2239] [error]: [Main] [WidgetGtk] Scale factor should be positive
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: Player exited with code 0
Nov 25 16:06:02 xibo-zotac-test player.desktop[1660]: Player exited with code 0

Ok, found a workaround by forcing the screen resolution in the profile setting for your display/display group.

Seems xibo-player-R4 have much difficulties detecting screen resolution by itself.

Hi Walid_MOGHRABI, welcome to the Community!

I can see that there is another post ongoing at the moment regarding the issues with 1.8 R4 not automatically starting. I have been testing your workaround and found that my own Player is now starting automatically as it should. I have updated the current issue report with this information, I wanted to say thank you for sharing this with the Community.

Many Thanks.

unfortunately, this solution doesn’t work for me.

Had the exact same issue and the suggested workaround did not launch the player in full screen (?!).

I observed Xibo player will start IF any other application is launched, so I just added this to my player startup script, e.g.:

# launch Xibo in a screen (optional. do install "screen")
screen -dmS "Xibo"  bash -c 'while true; do /snap/bin/xibo-player ; sleep 15; done'

# Work around 1.8-R4 startup issue
sleep 10; xmessage Xibo

Hope this works