Xibo on Linux: [HTTP] 400 Bad Request

I am trying out Xibo on Linux to reach our CMS server which is set to use https with a Let’s Encrypt SSL certificate. Windows Xibo versions work fine with CMS address using https. On Linux I am receiving ‘400 Bad Request’ errors and packet captures show the message as “Your browser sent a request that this server could not understand. Reason: You’re speaking plain HTTP to an SSL-enabled server port. Instead use the HTTPS scheme to access this URL, please”

Is there some step I’m missing where the Xibo client on Linux needs to be told to use https?

Ubuntu 18.04. Xibo 1.8-R4.

Thank you for your time.

hi lobbycanada
Do you have HTTPS enabled in the preferences / network?

written with google translator

I assume your talking about a client - > cms connection here (not player - > cms). The error you give is not a Xibo error but rather a webserver error.

I cannot tell if you set up your certificates correctly, but you will find out soon. This problem is simple. Your trying to connect to a HTTPS site with the normal HTTP protocol, e.g. http://xibocms:443, which is wrong ofcourse. Maybe you have changed ports for SSL and still connecting with http, e.g. http://xibocms:4443? Maybe you adjusted some redirect rules that are wrong? Anyway don’t expect any useful direct response without posting logs or configuration. If you want good help, supply us with what you did.

But yeah, this is definitely the direction to solver your problem. Just try it again with whatever URL you’re typing in your browser to access the CMS with https:// infront of it. Make sure to clean browser data and history to prevent unwanted old redirections. Test on other machine. If that’s not working, than please post your config.

In case anyone else has this problem I will post an update. It turned out that our web host is configured incorrectly where it is not truly https and it flips between https and http during its journey from client to CMS (Docker). By turning on ‘FORCE HTTPS’ I accidentally prevented access to the Xibo admin web interface and got ‘too many redirects’ errors (ERR_TOO_MANY_REDIRECTS), and had to get our web host administrator to manually unset ‘FORCE HTTPS’ via SQL.

UPDATE setting set value=“0” where setting=“FORCE_HTTPS”;

I’m just going to go back to Windows for now (which doesn’t seem to complain about it) and revisit Linux when we figure out how to have a pure https connection. Thanks for your replies.

I have the same behavior from the Linux player (400 Bad Request), and also the same ‘too many redirects’ when checking the “Force HTTPS” in the web portal; Windows/Android clients work fine.
Any solution to the broken admin interface after forcing HTTPS?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.

The Xibo Community site uses cookies. What are cookies?