Xibo install on vm of server 2016

I have did all steps and everything are installed correctly as how you guided.

But there is a problem which is,
when i write php -info in cmd ive got php version 5.6.31 but in iis manager > php manager i see the correct php version which is 7.2.21

2 different php version is listing they are in use.

so how can i remove 5.6.31 or change it to 7.2.21

Note: i removed that now i have only 7.2.21 installed. I checked that i added c:\php as user variable, not a system variable.
So added as system variable also. Mapping handlers and Fastcgi module settings all done.
rebooted system … still empty when i run. C:\XIBO_CMS\vendor\bin\php xmr.phar

I stuck on this…

Did you install the Install CGI for IIS support from Server Roles? You should also reboot the server after updating the path variable.

Here are all my Server roles and Features:



Did you also copy over these two files?
copy “php_zmq.dll” to your ext folder in PHP installation (ex. C:\PHP\ext)
copy “libzmq.dll” to your PHP installation folder (ex. C:\PHP)

Here is a sample of my config.json file:

Okay i have installed all features as same as on your picures now i get something

    PHP: syntax error, unexpected $end, expecting TC_DOLLAR_CURLY or TC_QUOTED_STRING or ' " ' in C:\PHP\php.ini on line 1941
PHP Fatal error: Uncaught PharException: phar "C:\XIBO_CMS\vendor\bin\xmr.phar" SHA1 signature could not be verified: broken signature in C:\XIBO_CMS\vendor\bin\xmr.phar:9
Stack trace:
#0 C:\XIBO_CMS\vendor\bin\xmr.phar(9): Phar: :mapPhar( 'default.phar' )
#1 {main}
       thrown in C:\XIBO_CMS\vendor\bin\xmr.phar on line 9

looks like you have a syntax error in your php.ini file. I would suggest you check all the lines (in particular 1941) in your file to ensure they are correct.

These are the important changes that are required:

Fastcgi.impersonate = 1
Cgi.fix_pathinfo = 0
Cgi.force_redirect = 0
Extension_dir = “ext”
Error_log = C:\PHP\php_errors.log
Date.timezone = "America/New_York”



Change settings to support XIBO requirements

All are correct except Date.timezone = “"America/New_York” is not. İ changed it to Date.timezone = “America/New_York” now there is no php syntax error but still there is phar error which is broken SHA1 issue. How can i solve that too ?

Can you confirm that your path variable is set correctly?

This is what mine is set for on my server

PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files\Microsoft\Web Platform Installer;C:\PHP;C:\Users\Administrator\AppData\Local\Microsoft\WindowsApps;

All same extra i have openssh path too.

This may be a stupid question but did you remove the “;” comments from the PHP.INI lines we edited?

Yes :slight_smile: i removed them. You also wrote some extensions 2 times i removed them also.

What is written on xmr.phar on line 9?

I followed your guide, and whenever I go to save a setting I get the web page below and nothing saves.

I will send you my custom build PDF file in a private email for you to validate your installation with.

I would also suggest you check if your folder permissions are set correctly CMS & LIB.

My email is timcotterell@gmail.com

For anyone installing Xibo on the MS Server 2016 and following the instructions I’ve provided should be aware that it will not work for version above Xibo 2.0.4. I am not sure what has changed beyond that version to impact how the CMS saves changes so some further investigation is required.

The guide that we spoke about has been posted at Xibo 2.1.X on Windows Server 2016