Xibo for Android no Menu items showing on menu bar


#1

So first off right away I know this device is not on the recommended list. But this device is far less expensive then the recommended devices. If they were used more then one time a year I would look at those devices.

That being said it works really well displaying all the content it is quick and content looks good. However once I setup up the app I can not change any settings in the app as when I bring down the xibo bar at top no menu items are available (HIDE | STATUS | Menu) are missing they are just not there. (You can see if the attached picture). I could use them as is but it gives me no ability to troubleshoot issues or verify connectivity.

This device is running android 7.1.2. It works on my phone and that is running 7.1.1.

I also tried 1.7 version of the android client with same results. Has anyone seen this behavior before?


#2

Yes we’ve seen it before on an inexpensive device. The issue is that from our side we can’t replicate it on any of the hardware we have access to, including alot of devices that aren’t on the list.

I’m fairly confident it’s something related to the way the device manufacturer has setup the application launcher.

If they come with a remote control, you may be able to summon the menu by pressing one of the context menu buttons. If so, you’ll find the context menu then pops up from the bottom of the screen where it has been hidden to by the device.


#3

Thanks, The menu button on the remote does not seem to do anything. Sad this device was very smooth as far as transitions and handling everything I threw at it.

I need to look at other options at this point anyways as I bricked the device trying to use a different firmware while using a faulty USB cable.

If these were full time displays I would for sure go with recommended hardware but hard to throw 150+15 for each display for a once a year event.

Thanks
Matt


#4

Perhaps look at something like the ODROID C1+ or ODROID C2. They’re not perfect, but they certainly aren’t bad. As ever, as it’s not a recommended device, please do get one and test with your use case before committing to a larger purchase.


#5

Hi Alex, I have same problem with new MX10 player Android 8.1, no settings menu on android player.
And I have just buyed 10 players
Can you help me please.
Thanks


#6

I never did get this working on specific boxes although I have not tired in last year. So you may want to consider return policy. I did try a different android launcher with same results.

Just something to consider…


#7

We’ve done some investigation on this and it happens where the device is built with firmware that is expecting there to be a physical “menu” button on the device or on a remote.

Android specifically disables those menus in that case. You’ll see the same in all apps that use a menu in the same way as we do.


#8

So what can I do now?


#9

You’d need to speak to the device manufacturer and ask them to fix their firmware.

We have a list of recommended devices which we’ve tested, so you don’t have to go through the hassle of purchasing poorly implemented devices for your projects. I’d suggest that if they can’t fix the firmware, you return the units and purchase from that list.


#10

Hello guys
I’m having the same problem here installing it on a FW-85BZ35F. Not exactly an inexpensive though…


#11

I’d expect you to have a menu button on the remote. That should trigger the menu.


#12

Hello
Thanks
Menu button on the remote exits the app and goes back to the android menu…


#13

Alex I can send you my player MX10 if you want test it.
Please send me the address where send.
Andrea


#14

We have a device now that does this, however it’s the same in all apps on the device. Fundamentally the firmware is built in a way that prevents apps from having menu items available. It’s a feature in Android 7, and it would need to be turned off at firmware level.