Xibo for android: cant connect to this cms

Hi Guys,

Just fooling around with the Android app however I can’t seem to connect to the CMS.
It always says ‘can’t connect to this cms’. Everything does work with a windows client (as i’m trying to connect to an existing xibo instance). Key is also correct and obviously, i’m able to access everything through a browser.

I’m running on xibo 1.8.10 and the latest xibo for android client.

Any suggestions on where i can look to troubleshoot this issue?


update: works on internal ip, but not externally. so not working on dns name (example.domain.com).

Without knowing how your network is setup, it’s hard to say, but Xibo for Android can definitely connect via hostname.

As it works by IP, it suggests you have a DNS resolution issue there somewhere - either the Android device can’t resolve the server name, or it doesn’t have access for some reason via name.

You’re welcome to sign up for a demo Cloud CMS to prove the Player side works as expected.

Hi Alex,

Sorry for the late reply, i do believe it should work however it doesnt on my end.
Current xibo installation is done as follows:

  1. zen loadbalancer to forward the traffic & have an SSL certificate in place
  2. multiple xibo instances running in the back
  3. installed xibo for android on my oneplus mobile phone & tried connecting through 4G to the cms : cant connect to that cms address (error)
  4. cms is accessable through webbrowser on that same phone using 4g
  5. tried on different wifi: same as above

is there any setting i’m overlooking? I do try to connect to HTTPS & HTTP (http traffic is forwarded to HTTPS throught the loadbalancer).

Make sure that SSL is correctly setup. Use Qualys SSL labs to run a test, and particularly ensure that you have no certificate chain issues, and that the protocols you have enabled are compatible for Android.

Check too that the load balancer is preserving the Host http header, and is adding the standard reverse proxy X-Forwarded-* headers as expected.

Thanks Alex, found the issue.
My certificate chain was incomplete. Making the full chain solved the issue!