XIBO CMS 3.2.0 installation error

Xibo CMS 3.2.0
PHP 7.4

I did the installation of the new version of XIBO 3.2.0 but it presented an error during the installation. I uploaded and unzipped without any problems. I started the process of checking the extensions and they are all ok. I went ahead to configure the Mysql data and then when I should go to the screen to create the administrator user and a password I return this error:

Slim Application Error
The application could not run because of the following error:

Details
Type: Xibo\Support\Exception\InstallationError
Code: 0
Message: CMS is already installed. Please contact the server administrator.
File: /www/wwwroot/app.pontods.com.br/lib/routes-install.php
Line: 85
trace
#0 [internal function]: {closure}()
#1 /www/wwwroot/app.pontods.com.br/vendor/php-di/invoker/src/Invoker.php(82): call_user_func_array()
#2 /www/wwwroot/app.pontods.com.br/vendor/php-di/slim-bridge/src/ControllerInvoker.php(47): Invoker\Invoker->call()
#3 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/Routing/Route.php(384): DI\Bridge\Slim\ControllerInvoker->__invoke()
#4 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/MiddlewareDispatcher.php(81): Slim\Routing\Route->handle()
#5 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/MiddlewareDispatcher.php(81): Slim\MiddlewareDispatcher->handle()
#6 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/Routing/Route.php(341): Slim\MiddlewareDispatcher->handle()
#7 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/Routing/RouteRunner.php(84): Slim\Routing\Route->run()
#8 /www/wwwroot/app.pontods.com.br/vendor/slim/twig-view/src/TwigMiddleware.php(125): Slim\Routing\RouteRunner->handle()
#9 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/MiddlewareDispatcher.php(147): Slim\Views\TwigMiddleware->process()
#10 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/Middleware/RoutingMiddleware.php(59): class@anonymous->handle()
#11 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/MiddlewareDispatcher.php(147): Slim\Middleware\RoutingMiddleware->process()
#12 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/Middleware/ErrorMiddleware.php(107): class@anonymous->handle()
#13 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/MiddlewareDispatcher.php(147): Slim\Middleware\ErrorMiddleware->process()
#14 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/MiddlewareDispatcher.php(81): class@anonymous->handle()
#15 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/App.php(215): Slim\MiddlewareDispatcher->handle()
#16 /www/wwwroot/app.pontods.com.br/vendor/slim/slim/Slim/App.php(199): Slim\App->handle()
#17 /www/wwwroot/app.pontods.com.br/web/install/index.php(101): Slim\App->run()
#18 {main}

It was about 20 seconds loading without success on this Database configuration screen and then immediately presented the error message mentioned above

This message is shown when the installer tries to load install step 3 (collecting Auth/DB details) but the web/settings.php file already exists.

Can you try starting from scratch with a clean system and then show us the /library/install_log.txt file?


I did just run a quick successful test when using an existing database, and it worked fine, so doesn’t seem to be a general problem.