Xibo clients connect, but won't download content

CMS Version


Installation Method

Docker (modified image for dynamic ports configuration)


I’ve installed the Xibo CMS and XMR on our platform, running in separate docker containers behind an nginx load balancer.
CMS runs fine, I can add displays by code and receive screenshots and logs. The displays do fetch a configuration and I can see the configured layout ids are provided, but the displays don’t seem to download any content. Looking at the display management all files show ‘0’ in the column "Downloaded.

When investigating the clients by running a Windows client on my laptop, I see the following error in the logging:

<method>FileAgent - Run</method><message>Web Exception in Run: The remote name could not be resolved: 'xibo-web'</message>

The requiredFiles.xml of that client has the following configurations:


I tried reconfiguring the device, but get the same error every time. I can’t find where the ‘xibo-web’ hostname is coming from. In my CMS settings XMR_ADDRESS and XMR_PUB_ADDRESS are set to the right hostnames and in the Windows Client logging, I also see:

<trace category="Audit">XMDS Location: https://the-right-hostname/xmds.php?v=5

Am I missing something here?

After investigating this issue I figured out that the SOAP endpoint uses the hostname of the container itself. So I added these headers in my nginx-config and it is working fine now:

proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.