Xibo API "The resource owner.... "

Hello Forum!

I followed the manual for the API on this site. 1.8 API Introduction

I did everything right because yesterday all worked fine. Today i restarted the server and wanted to create a layout but it response me:" The resource owner or authorization server denied the request.

The IP of my Server changed so i changed the IP in the “Manage Enviroments” section in the URL field. But i still get the error.

Do you have any ideas? I cant do any request by API.
CMS: 1.8rc2
API Programm: Postman

You will need to do access_token api call and assign that token to your saved environment ie the first step in my guide (after configuration).

1 Like

I did this yesterday too and it worked. I got the token and added it to the value of access_token. If i do access_token api Call i get the message:
“grid”: false,
“success”: false,
“status”: 400,
“message”: “The request is missing a required parameter, includes an invalid parameter value, includes a parameter more than once, or is otherwise malformed. Check the “access token” parameter.”,
“id”: null,
“data”: []

I dont know whats the problem is. Should i delete the application and repeat all steps?

Make sure that you have selected the correct environment and that your environment has correct cms address and clientId, clientSecret of Postman application in your CMS.

Then that the post call has all parameters

Okay now that works fine.
But when i want to create a layout it give me this response:

What’s wrong? On the left in “Authorization” is “No Auth” activated, Is this the Problem? I get this error in every API Call except for Access Token.

So, each call will need this in headers:

now if you’re using {{access_token}}

then in your environment you need to have

and when you first call access_token, you need to select it and set as a access_token

Once that is set, the Bearer {{access_token}} in all other calls will use the access_token you saved and should work.

1 Like

Now it works nice!
Thank you