Xibo android not fitting full screen


#1

Hey All.
So slowly i am getting the Xibo installation exactly how i want it.

I have noticed that there is a black bar (area) around the left, right and bottom edges of the screen whilst the show is playing. The show aligns perfectly to the top.

When the menu boards are showing, they show correctly, aligned to the top and bottom as expected.
See attached.

Any way i can get rid of these?


#2

Can you confirm the following:

  • What version of Xibo for Android are you running?
  • What Resolution are the screens you’re using?
  • What Resolution is your Layout set to?
  • In the Layout editor on your CMS, does the Region cover the entire canvas?

If you can export the Layouts you are using with these Displays and send me a download link in a private message, I would be happy to take a closer look and find out what is causing the issue.

Many Thanks,


#3

Check your screen scaling settings on the android devices.
I’ve had to adjust that for some of mine.


#4

What version of Xibo for Android are you running? 1.8
What Resolution are the screens you’re using?: 1920x1080
From Xibo Status: 1920x1008
What Resolution is your Layout set to?: 1920x1080
In the Layout editor on your CMS, does the Region cover the entire canvas?: Yes
Screen Make Model: Toshiba / 32W3754DB - Although it is the same with a much bigger Samsung screen


#5

Where would i find the scaling settings?
I looked in accessibility, and changed the font size.


#6

This must be device dependent.
On a random no-name brand device, I don’t have any scaling options.
on our Shuttle NS02A devices, you go to Settings/Display/Screen Scale.
maybe that is not a native Android feature.

maybe reach out to the device manufacturer. (what devices are you using?) Edit, nevermind, just realized I had replied to another one of your posts and you mentioned the devices. that is very similar to my test device that does not have the scaling option…


nevermind again! just found the settings.
see the pictures I’ve attached. see if your setup is similar.
need to go to “Droid Settings” in my case, not the regular “Settings”





#7

I found the droid settings. It is set to 100%. It is really strange because i have my own test stick at home on a 55" LG TV, that looks perfect.

On a 55" Samsung and the 3x 32" Toshiba’s it does the same black bar issue.


#8

do you still have the black bars with it set to 100%?


#9

Hi. Yes I do. :frowning:


#10

I guess here are a couple thoughts.
Does your test stick from home work fine on the Toshiba’s?
Do you know the model number of those Toshiba’s?
Maybe bring another TV/Monitor that is 1080p to the location to try? a lot of computer monitors have HDMI input and most are 1080p.


#11

I would recommend trying the following:

  • Select the Display settings option in your CMS.
  • Click on the down facing triangle at the end of the Display Profile you are using with your Android Player and choose Edit from the menu.
  • Click on the Location Tab. You should see a option named screen dimensions. Enter the following into the box and save:
    0,0,1920,1080

Once you have done the above, I would recommend restarting the Xibo Player to see if this resolves your issue.

It sounds like you are using an Android TV box to run the Xibo Player, is this the case?

Many Thanks.


#12

That did the trick. :smiley:

I have just bought 4 more licences too. :smiley:


#13

That’s great news, I’m glad the issue is now resolved.

Many Thanks.