Xibo android client takes lots of time to load the layout

I have a fast internet connection, but whenever Xibo Android client wants to load a new layout it takes a long time to load the layout (around 5 minutes) even when the layout is less than a MegaByte.

Do you have any idea why is this happening?

Thank you for your message. When a change is made to the Schedule for a Xibo Player, those changes will be received by the Player in one of two ways:

  • The first option is that the Display will contact you CMS on or near to the Collect Interval you have set for it. If the Collect interval is set to 5 minutes for example, it will be up to 5 minutes before the Display has contacted your CMS and been informed that there has been a change. This is when those required files will then be downloaded.

  • If you are using a compatible version of CMS and Android, you may instead use XMR. XMR when configured will ensure that any changes to the Schedule are pushed to to the Player as soon as possible, generally within a very short time frame.

Have you configured XMR for your CMS? If yes, can you confirm how long it takes to receive a screenshot from your Display when requested using your CMS? Please also confirm the version of CMS and Xibo for Android Player you are using.

Many Thanks.

I am using Xibo’s Docker which has CMS and XMR. I have no idea what do you mean by configuring XMR. My Cms version is 2.1.0 and xibo client android version is 2.
Actually, it seems that the client is trying to fetch the new layout, but it takes a long time to load it. The reason is that the client go to loading page but it doesn’t load it fast regardless of size of the layout.

Thank you for your reply. Xibo CMS does not have XMR fully configured out of the box. With your Docker setup you will need to configure XMR for your network so that it is working. These are the instructions for XMR setup on Docker based installs:

You also haven’t confirmed what your Collect Interval is set to. Log into your CMS and click the menu option named Display Settings. Now click the button at the end of the Profile named Android and choose Edit. This will open the Edit Profile window as shown below:

You can see in my screenshot that the Collect Interval for my Players is set to 1 minute (this is just an example, you should not use 1 minute collections ideally unless you are troubleshooting). What is yours set to?

Many Thanks.