Xibo 1.8 -> 2.1 - Cannot Migrate Data (Phinx) Windows Server 2016*


I have moved from a Docker instance to an IIS server setup. Xibo 2.1.0 works just fine; so long as I am willing to redo all of the displays we have already done; layouts, media, campaigns, the whole shebang. So, I imported the latest backup into MySQL, and copied over all of the media. Seemed like it would be easy peasy – however, I am now stuck at the “CMS is offline” part, where you are apparently supposed to migrate the data. However…none of the migration solutions I have found in the support forums have helped. What specifically is the best procedure to upgrade from 1.8 to 2.1? It is apparently not the same as 1.8 -> 2.0, as none of the existing solutions I have found have worked for me.



NOTE: I found the solution was to fix the LF line endings to CRLF. After that, things seem to be working just fine. :blush:

Eh, nevermind – did not matter. Xibo is literally showing nothing after the migrations were successful. Even if I create an entirely new layout, the preview and the actual layout displays nothing but the background color of whatever is previewed/played. Where 1.8 worked well, I am finding that I am thusfar more frustrated than anything after the upgrade. I have validated that WMV/MP4 files play in WMP, so that is not the issue. As well, not even text widgets, images, or a clock are shown in a layout. Any ideas, folks? This is impacting both existing and new assets alike.

I have tried changing layer levels, etc, but none of the content is ever visible.

Editor view


End of Preview (nothing ever shows)

Also, it seems to be wonky when trying to access the media content in some fashion. If I download a file in the library, the retrieval always gives me a 0 byte file, although in the library itself, the content shows the correct filesize. NOTE: This happens with images and PDFs as well as videos

Downloaded File

Actual Library Entry

Actual Library Filesystem

Database Entry

I have not performed an upgrade yet but what file or area of code did you edit with the CR?

Skidoo – there was a Phinx.bat that is recommended for all Windows server-based setups (see Upgrading to xibo v2, unable to do database migrations) – I do not know why, as I am not a PHP person (C#/Java/VB/JS are my main languages). However, it was a non-default file that just makes it easier to run the phinx commands to do a migration. Without changing the line endings to CRLF, the file was literally just one large “comment” (REM statement).

Regardless of that part, the worst that I should be seeing is problems with my migrated data from my understanding. Instead, even new layouts are not working. I am considering blowing everything away, which makes me quite discontented, and recreating everything from scratch. However, that seems to defeat the entire point of having an “upgrade”, and I would be better off just going back to 1.8.

Do you think if you upgraded from 1.8 to 2.0 first and then upgrade 2.0 to 2.1 would work?

Skidoo – I am uncertain; I can try it, as I am already spinning my wheels here. I am losing a lot of time, however – if it does work, I think there should be some sort of failure generated when trying to perform an upgrade that will not work for the end user or Administrators.
I will advise once I get this tested. Thanks :slight_smile:

My immediate thoughts on this one is that the conversion of the data to the new SQL database didn’t properly create the necessary data in specific tables. If you use MyPHPadmin GUI web tool for interrogating your database, you might find what looks different between one you created post conversion.

As a side-note from more research, it seems entirely related to the inability to serve files properly. Each file that is pulled out of the library has 0 bytes; javascript, html, fonts, videos – all of it. When the player triggers, almost everything the player downloads from the server is 0 byte files, although they have appropriate sizes in the Filesystem. I have confirmed that there is adequate access to all of these files for the webserver, so I am flummoxed as to why it is not properly serving them up.

Many 0-Byte Files

Previous Copy of Same Library

As you can see, there is a major issue with truncating all the data, or just not accessing it properly. As well, the client seems to give up downloading the media, or something:

0 Percent Downloads

… and XMR is functioning properly? aka you have it setup to run in your task scheduler.

Skidoo – It seems to be – I even restarted it just to make sure something was not wonky

anything reported in your error logs? also check the PHP error logs

Skidoo – no Xibo errors, outside of those generated when I have deleted the Xibo Library to reattempt download on the client the player is on. PHP errors have none either for the past 24 hours.

I can’t see a firewall causing the issue but who knows. I am at a loss on this one.

Skidoo – same here :slight_smile: I removed the firewall first and foremost! I’ll let you know once I blow it all away and set up the new instance from 1.8 -> 2.0.