Xibo 1.7.5 Setup Problem connecting to Remote MySQL Server - Resolved

I’m standing up xibo 1.7.5 in a separate folder on our web server (XAMPP) that is running our current Xibo CMS (v 1.7.4).

I was unable to get the localhost mysql server instance to do anything but authenticate as the anonymous user (I don’t know enough about MySQL to address that with XAMPP) so we are trying to point to our standalone MySQL server.

From our application server, I can ping the MySQL server. However, when I provide the IP address or DNS name for that server to the install.php during the database setup step, it times out connecting to the MYSQL server.

Could not connect to MySQL with the administrator details. Please check and try again. Error Message = [SQLSTATE[HY000] [2002] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ]

My administrator has been able to remotely administrate that server and created an admin id and password with the proper GRANT permissions to create users and tables.

Any idea why xibo might not be able to see the remote server while we can ping one to the other? Is there a php setting for this sort of connection I should be looking at or something with Apache?

Is this a Windows machine? If so, the problem maybe that you have already connected to the machine with one set of credentials, for drive mapping or what not, and then when Xibo tries to install, it is presenting a different set of credentials, which Windows does not allow. You can only connect across a network to a Windows box using one set of credentials. (Although you might get away with using one set of credentials via the Computer Name, and a second set via the IP address)

If you run “net use” on the application server from the command prompt, do you see the MYySQL server IP of name listed? If so, that could possible be the problem.

I ran netstat on the windows app server and there are no connections listed for the MySQL server, which is running on RedHat. Thanks, though, good suggestion.

I would get your administrator to make the database and grant all privileges on it for a new user for Xibo to use, then when you install Xibo use the option to install in to an existing database and enter the details for your database server, and user account there.

Worth a try. Just an empty database? Xibo will set it up once connected?

Yes, just an empty database, and a user with permissions to select/insert/update/delete etc within that database from your remote machine.

Then in the installer, choose the existing database route and it will install in to the database you’ve provided with the credentials you give rather than trying to create a new database and user for itself with administrative credentials.

Turns out we needed to attend to our iptables on RHEL for the mysql connection to succeed. This was a new server and nothing had been opened up by the administrator yet.

Fair enough. Glad you got that working. I discounted firewalls as the problem since you said your Administrator was able to connect and create databases remotely with the administrative credentials.

So he was, which is interesting. It was literally the last thing I considered given everything else we knew.

I should add, I’m only in contact with the MySQl admin, not the RHEL admin, so I might not be getting all the details. I think this issue is closed for now.

The Xibo Community site uses cookies. What are cookies?