What step am I missing?

Hello all,

I have installed Xibo several times over the years and have found it pleasantly easy. Each time I have installed it, in the end, the project was scrapped. This time I am making it a priority. I can easily justify ANY costs associated with the install by the amount of time our marketing department will save just by not having to log in individually to each of our displays and download/run the current powerpoint.

So yesterday I tried and tried to install CMS 1.8.2 And everytime I install it, when I go to the webpage, there was nothing there OR a few times it just listed the files. Is there no longer an install.php ?

I ended up installing 1.7.9 but would love to do 1.8.2

I am trying to install on Debian 8

Thanks,
Danno

Did you try to install it in docker or in a manual/custom way ie similar to 1.7 series?

At a guess it was manual/custom installation - http://xibo.org.uk/manual/en/manual_install.html

Which is fairly similar to 1.7 installation process (requirements might be slightly higher) and then there are couple of additional steps, as you need to make environment changes (documentroot and url rewriting) and make sure XTR/XMR are working (XMR isn’t essential, but ideally you will want that working), instructions for all of that are linked in the url above.

Perhaps those additional steps are what you’ve missed there.

Peter,

Thank you for the reply. I am trying now to do the tutorial here: Xibo 1.8.0 with Docker on Ubuntu 16.04

However, when I start it up and go to the address, I am getting: Fatal Error - sorry this shouldn’t happen. SQLSTATE[28000] [1045] Access denied for user ‘cms’@‘172.18.0.4’ (using password: YES)

I didn’t see anything in the tutorial on creating a DB. Is that a missing step? I am not sure how to do that. I had hoped that tutorial had everything I needed to do in it.

Thanks,
Danno

The guide does have all the steps required.

At a guess, you either missed setting a password in the config.env file for your MySQL user, or you set it to something that is non-alpha numeric (ie made up only of A-Z a-z 0-9).

There’s a link to a password generator that will give you what you need.

Once you have that corrected, then you’ll need to destroy the containers, delete the database container data, and then bring the containers up again

docker-compose down
sudo rm -r shared/db
docker-compose up -d

Got it. I had missed the step of putting in the password my first go around. I had corrected that and it still wouldn’t work but the commands:

docker-compose down
sudo rm -r shared/db
docker-compose up -d

Remedied that situation. Thank you so much. I was more frustrated with myself than anything. A note in the tutorial with those 3 commands referenced (if someone makes the same mistake as I did) might be beneficial. I have saved them locally. Thank you!

The Xibo Community site uses cookies. What are cookies?