Webpage doesn't displays well in Android player

Hi friends,

We have the following webpage you canm access to test http://soporte.techex.es:3000/

I have been testing with different players (DsDevices, Minix and Geniatech) and I have the same problem in each one. Webpage is displayed “displaced” as you can see in attached picture. When I see this webpage on my laptop I can see it well. We have a background image 1920x1080 and I don’t understand why Is not shown whole. I attach screenshot with problems.

I have tried changing webpage properties in layout design (open natively, best fit and manual position) being the same result.

Can you help me, please? I’m using Version 1.7.7and Xibo_for_Android_v1.7_R62

Thanks in advance for your help.



It seems to be displayed fine on my windows client - at least looks the same as in the browser.

Would be good to:
Upgrade CMS and player to 1.7.9 version
Make sure that IE11 is installed and that those registry entries are correct for your machine - Enabling HTML5 in the Windows .net Player

Since 1.7.8 player should make those changes during installation, but you can double check if everything is fine.

If you’re using Windows 10, make sure that in display settings the Change the size of text, apps and other items is set to 100%.

As for android, R62 and 1.7.9 CMS should suffice

Of course double check that your monitor is set to 1920x1080 resolution as is your layout.

In both cases, you can set the Xibo resolution in display profiles - the default should be full monitor screen though.

You might want to inspect your web page in chrome console and see what it does not like there.
Your background image has transparent part on the right - so that’s why there is ‘black’ (or background) colour when you open it in Xibo.

I’m not sure what’s more Android browser might not like about it though.

In addition to what Peter has said, try changing the mode you’ve got your webpage set to in the widget - so try “Open Natively” or the other options and see which one works best.


First, thanks for your quick reply.

I have double check with theree different monitors and confirming their settings, also I have double checked mode webpage set in the widget (and Android display settings) and always I have the same problem. The page is cut on the right side and do not know why.

As this is a quick test, can anyone test this webpage on an Android player?

I’m going to install CMS 1.7 and upgrade Android version, but it takes me time.

Thanks for your help

Best regards


Open the Player status screen. What is shown there for the screen dimensions?


I can send you a picture of it if it gives you relevant information.



If you upload a copy of the background image from your webpage as an image in Xibo and put that on its own on a layout, is the whole thing shown? Or is that cut off too?

As image it is shown whole.

It seems that the link to your site can’t be reached now, could you please make it available so we can test it on android devices?

Hi Peter,

It is available again.

Thanks for your help


We’ve tested your web page on a various android devices.

The open natively option will not work, I believe it looks like in your screenshot with it.

The Best fit with correctly specified size ie 1920x1080 (assuming that’s your monitor resolution) seems to work fine on all of our android devices, we’d suggest that you try that.

Hi Peter,

I have tested with “best fit”. Fixing width and height to 1920 and 1080 it looks better but not fine at all. Now I’m seing a black vertical strip on the right that is not on the image that we use as background. I attach screenshot.
Can you confirm me you don’t see this strip?

Thanks again for your help


It looks the same in the browser, and your background image actually does have a transparent bar on the right, so that’s why it’s there in Xibo as well.

or if you open it in gimp/ps

Attach original background image too


Thank you very much Peter. I was sure I have tested it several times but now I’m seeing background image was wrong from the beginning.

I feel so much has wasted your time without need.
Thanks for your help and support.


Well, hopefully your webpage will look as you want it to look now, so that’s good :slight_smile: