Web Page Display Cropping Image


Using a DSC9 running Xibo in portrait mode. Displaying a webpage that shows up fine when ran on a PC in portrait mode, but when displayed through Xibo it gets cropped. It is set to open natively and background transparent is left unchecked.

The monitor is 1920x1080. The DSC9 resolution is set to best choice and has selected a 4K option. When I changed that to 1920x1080 I saw no change. It appears that the screen is on a zoom setting of some sort to crop the outer edges and I’m unsure if I am missing something obvious here. Thanks!


It might be the website itself detecting that it is a mobile browser and making some adjustments. Do you get the same result if you open the URL in the web browser from the applications tray on the DSCS9 (closing Xibo to do that)?

Hey Dan,

When I open it on the web browser it crops it in a different way, but allows me to scroll to see the missing content. When I open the same webpage on a browser on a PC it displays the content correctly. I currently have that layout set to open the webpage natively. When I choose the best fit option or manual and set the 1920 x 1080 parameters and reboot I only get a white or black screen.


The website is preventing itself from being “framed” which is the technique we use for best fit/manual.

It sounds a lot like the website is doing some work to size itself depending on who’s looking - unfortunately there isn’t a lot we can do about this :cry:

If you’re happy to share the link with the help desk, you could run it past them for confirmation.

I also have zooming issues when using the native view. Sadly most websites include the X-Frame header these days. What kind of native view is the webpage widget using on Android? Is it a android.webkit.WebView? It must be possible to force the native view to size of the display (like with iframe) or give some sort of zooming instructions (like in the Chrome browser on Android: display as on desktop).

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.