Weather forecast is not displayed


I did a manual installation for testing.

In it I am using CMS 4.0.4 and an Android v4 R401 apk, which is installed on a TVbox Tx3 Mini, with Android 7 or 11.

Everything works very well, except the Weather Forecast Widget and RSS.
In these 2, only a black screen is displayed, In the apk log several errors are displayed.

I tried changing the dns to, and and it didn’t work. - In CMS V2 and Apk v2_r216 on Android 4 I solved this problem using these DNS’s.

But with this new CMS and APK using Android 7 or 11 the problem returned, and even changing the DNS’S the Widgets don’t work. Because this always happens with widgets and RSS tickers.

The android player makes requests to its local webserver to get the data for weather/rss/ticker, etc. For the connection to be refused to this likely means that it isn’t running or wasn’t able to start.

I think put the display into auditing mode and set the log levels to audit, Display Client Logs | Xibo Digital Signage, wait for it to collect (or restart it twice) and see if there is anything more detailed logged.


Thanks for you reply.

I turned on logging on the player, and I didn’t find anything that helped me understand what is causing this.

I really don’t understand, if the player can connect to the webserver and download the videos, why doesn’t it work with Weather/Rss/Ticker?

See your inbox, i send some information from the logs, maybe you can identify the problem.

Thanks againd.

Thanks for the logs - but this is not an issue with the player connecting to the CMS, it is an issue with the player starting its own webserver and connecting to it.

Each player runs a web server which listens on http://localhost:9696 and serves HTML based widgets and other assets.

In your case this web server is not able to start.

You’d need to put your player in auditing mode to see additional information for why it is not able to start.

When you say to put the player in audit mode, it means to go to the Player Settings tab and in the LOG option set AUDIT. ?

And Then go to the Player ADVANCED tab and set a date for the audit?

If that’s all, I’ve already done it, see the images below.

Also see what the CMS TROUBLESHOOTING tab looks like.

If that’s it, where do I see the audit logs?
Is it in ADVANCED > LOG in the CMS?

I tested another player, yesterday it worked fine,

Today, it stopped working.

See this player’s log.

Now at this point, I disabled DHCP on the android, set a Manual IP and changed the DNS to and

And magically the weather forecast started working again.

Below are the latest logs, but with the DNS changed to the numbers above, and with the weather forecast display working.

It seems that the blocking is related in some way to the DNS, (But this doesn’t always work, sometimes even when changing the DNS the weather forecast is not displayed)

Maybe this will help you understand what might be going on.

Hello Again.

Doing some more tests, I discovered something strange, which may help in solving this problem.

My internet router has the ability to create 2 networks.
As I said before, in the guest network, I configured dns and

And with this DNS configured, the weather forecast worked. Although,
after restarting the device it stops working again, and to get it working again, all I had to do was connect to the other network created by my router (which doesn’t have the dns changed) and then go back to the guest network with the dns changed.

In some tests, I didn’t even need to go back to the network with the changed DNS, I just needed to change networks.

And now lastly,
I did a test increasing the waiting time until the player starts from 60 seconds to 120. and this way, when restarting the weather forecast also worked.

I didn’t have time to test this last option to see if this solved the problem, but there may be a solution.

I test on TX3MINI and T95-S1, the 2 use a s905w cpu.

With this information,
Can you get an idea why the xibo player might be behaving like this on my mediaplayers?


I did some more tests and it seems it has nothing to do with delaying the player’s start.

Now, not even changing networks is working.

Regardless of what I do, I keep getting the connection refused error.

This is very frustrating.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.