Video Streaming

We have a video streaming server that allows for both http and rtsp streaming of live tv content.

The xibo server is a server 2012 VM and deploying to 15 android clients.

We are currently using version 1.80 of Xibo

The issue I’m having is being able to display a video stream. We ran this in a test environment using 1.79 I believe and were able to stream to our DSDevices using a http connection to our onsite media server. Alas now we have created a server with version 1.80 installed on it we cannot display the video at all.

I can play the stream through VLC and can also play the same stream through the browser on the android device but when it is entered on xibo as a local video or even through hls it doesn’t work. The URL I’m using for it is


This is then scheduled as a campaign to play always and assigned to the specific client. However with the local video it just simply does not connect and as HLS it just shows the frame/region grey screen on the client but doesn’t play.

Any advice on what to do with this would be fantastic

LocalVideo would be the best route. There’s no functional difference between 1.7.9 and 1.8.0 in the way local video is handled, so I’m surprised that isn’t working for you.

Are you able to try a 1.7.9 Player and see if the problem persists?

Possibly Alex, where would I get one from and how would this be applied?

Odd that it worked when using 1.7.9 but not with the updated version.

You can download the 1.7.9 Player for DSDevices or standard hardware from here:

If you need a temporary 1.7.9 CMS, you can start a 14 day demo CMS with Spring Signage from the Shop on the same website.

Thanks again Alex.

As we have bought the DSDevices and their associated licenses this won’t be affected by installing the 1.7.9 player will it and is it necessary for me to add a same version CMS seems like a retrograde step to resolving an issue. Albeit it may resolve it.

I’m not suggesting this as a resolution. Merely so that we can test the two side by side.

There are no changes in the way local video is handled, and so I can’t see any reason why one would work and the other wouldn’t. However, as you know it works under 1.7.9, then if we can get them consuming the same stream and the issue is still there, then that’s grounds for us to look in to that further.

The licence won’t be affected.

The only difference from my end also is that the 1.7.9 was tested on a windows 7 workstation as the server. Now I have created a windows 2012 R2 Std installation. I can’t see how this would cause an issue though as the video is being called from another local server to be played on the DSDevices. I can play directly from the DSDevice using VLC and the browser but not through Xibo which I’m finding confusing.

It’s not a critical issue for me right now but could be going forward when requested to add streaming content.

Are you using the RTSP stream, or HLS with the LocalVideo module?

Does a test HLS stream work? eg

Some progress there Alex. That works perfectly. I now need to find out why it is not working with our m3u8 url which works on both vlc and the browser.

1 Like

The stream is on our TV box which is linux based.

The stream is located in ‘/var/lib/etvd/hls/BBC_NEWS_HD/BBC_NEWS_HD.m3u8’ on the linux server

I’m connecting to this via the ip address of the server


That should be OK, assuming the format of the stream is suitable. Perhaps something changed in the way the stream is encoded between your original test and now.

Yes, I agree it should be. The test was only done last week and there have been no changes. There is clearly something amiss with the encoding I think though as I have run other stream tests from external sources and all work but the internal ones from our Media Server do not through Xibo, only through VLC and the browser.

If the Browser in question is Chrome, then that will bring it’s own playback codecs, as does VLC, so it doesn’t represent the codec set available to Xibo for Android, which is why you’ll see a difference.

Is the codec set modfiable for Xibo for Android to allow this to play? The browser was Microsoft Edge but doesn’t play in ie and firefox. Plays on the Android browser though on the DSDevice.

I’m afraid not. The codecs available are baked in to the firmware of the device.

ah ok… looks as though the stream is encoded with libx264

H264 is definitely supported, so it could be simply a parameter of that - ie frame rate, bit rate etc

This is the encoding that’s used on the streaming server

-i “rtsp://localhost/live/BBC+NEWS+HD?overrun_nonfatal=1&fifo_size=50000056” -vf “yadif=0:-1:0” -flags +global_header -c:v libx264 -force_key_frames expr:gte(t,n_forced*3) -preset veryfast -ac 1 -b:v 630k -b:a 80k -s 1024x576 -c:a libfaac -map 0:v -map 0:a -bsf:v dump_extra -hls_time 3 -hls_list_size 10 -hls_base_url ‘/hls/BBC_NEWS_HD/’ -hls_flags delete_segments ‘/var/lib/etvd/hls/BBC_NEWS_HD/BBC_NEWS_HD.m3u8’

I’m afraid I don’t know what all those options mean.

Have you tried a different channel for example?

Failing that, try using the RTSP stream directly instead of HLS.

I am seeing a similar if not the same issue on my system here. With the "Production CMS (Version 1.7.6) we are using several layouts for Live TV. We do this using an rtsp stream. On the test environment using CMS 1.8.0 the same rtsp stream will not play.

The layout uses this format: rtsp://
I have also tried this format:

This is from the client’s log:

84 2017-04-07 10:10 Unable to start XMR queue: class java.lang.IllegalArgumentException/ Unable to resolve host "": No address associated with hostname
83 2017-04-07 10:10 XMR unresponsive, issue reconfigure.
82 2017-04-07 10:05 Unable to start XMR queue: class java.lang.IllegalArgumentException/ Unable to resolve host "": No address associated with hostname
81 2017-04-07 10:05 XMR unresponsive, issue reconfigure.
80 2017-04-07 10:00 Cannot display video. Uri=rtsp:// What=-38. Extra=0.
79 2017-04-07 10:00 Cannot display video. Uri=rtsp:// What=-38. Extra=0.
78 2017-04-07 10:00 Cannot display video. Uri=rtsp:// What=-38. Extra=0.

This is NOT on a production system, I’m adding this for community support only.

Thank you for a great product!

Kartr Higgins