Video looping bug?


I’ve been playing around with Xibo cms v1.7.4 and Android trial v1.7R54 and got some weird behaviour with the following layout:

  • Region1 contains a 15 secs video with looping on
  • Region2 with a still image for 45 secs duration.

After the first full video run, it will continuously restart after 9-10 secs until Region2 expires.

I can consistently reproduce this behaviour with any video that is at least 9-10 secs shorter than Region2.

Any clues?


Is the Video itself set to loop, or is the region set to loop? And what duration do you have on the video?

Hi Dan,

Thank you for your quick reply!

Region1 is set to loop. Video duration set to 0, so no looping available for the video itself.

From your questions I realized that maybe I need to set some duration for the video. So I run some tests and find out that if I set some video duration (1 sec was enough) and set looping on (for the video itself), it worked as desired.

But then, I added a 2nd video to Region1 (still their added length is ~10 secs shorter than Region2 duration) to be played sequentially in a loop. In this case I couldn’t set looping option for each video (for obvious reasons), so I had to set the looping option for the whole region.

In this last scenario, the original problem showed up again: it will play both videos completely and in sequence in the fisrt sun; for the next loops it will play ~10s of the first video then ~10s of the second, and so on.

Thank you again.

Sorry for the delay - we’ve had this exact problem before.

I won’t bore you with all the debugging details - it turned out to be a problem with the video codec (in our case they were exported from PowerPoint).

Re-encoding the videos to something supported natively by android fixed the issue - see

Hi Dan,

I will follow the link and re-encode the video and see if this solves the problem.

I’ll let you know.

Thank you!

Hi Dan,

Even though the link you provided refers to a different kind of problem (not being able to play a video at all), I’ve re-encoded the video as per the instructions using avconv.

Unfotunatelly, this didn’t make any improvement to the problem I reported.

Please let me know what else can I try.

Thank you.

I pointed you there for the re-encoding advice rather than the whole issue :smile:

I don’t have anything else to suggest at the moment - if we can have an export of your layout then we will run some tests here.

@Peter Can you organise that please?


Could you please export your layout for us to test?
You can send me download link via pm, if you don’t want to post it here.


Hi Peter,

Thank you and Dan for the follow-up.

You may download the exported layout from the following link:

Please let me know if there’s anything else I can help with.