Upgrading Xibo 2.0.0 or newer on a Windows Server 2016

PLEASE NOTE THAT I AM ENCOUNTERING OTHER ISSUES WITH THE DATA MIGRATION (Fresh installation of Xibo may be fine).

CURRENTLY INVESTIGATING PROBLEM.

If you are attempting to upgrade Xibo 2.x.x and are using Windows Server 2016 with IIS (as previously documented)

Launch "IIS Manager"
Stop your IIS “Xibo” CMS web site

Launch "Task Scheduler"
Stop the “XiboXMRstartup” task in “Task Scheduler” to unlock the open file in your vendor folder

Now move the current CMS files to a different folder to preserve your old installation. Change the destination folder to match what’s on your own webserver
Create a new folder C:\Xibo_OLD
move C:\Xibo_CMS*.* C:\Xibo_OLD

Copy zip folder …/xibo-cms-x.x.x/. contents containing the new version files to C:\XIBO_CMS*.*

Now we need to copy custom XMR file to new version.
Copy c:\Xibo_old\vendor\bin\config.json c:\Xibo_CMS\vendor\bin*.*

Now we need to copy XMR startup batch file to new version. (assuming you created one as shown here)
Copy c:\Xibo_old\xmr.bat c:\Xibo_CMS*.*

This last step will put your Xibo into upgrade maintenance mode.
Copy the old CMS ‘settings.php’ to the new CMS \web folder.

   Copy c:\Xibo_old\web\settings.php c:\Xibo_CMS\web\*.*

Open a command terminal
cd into your installation folder C:\XIBO_CMS
Run this command:

php vendor\bin\phinx migrate -c phinx.php

If you don’t see any migration results from the above command do the follow:

  1. Copy folder “app” from “vendor\robmorgan\phinx” to “vendor\bin”
  2. Copy folder “src” from “vendor\robmorgan\phinx” to “vendor\bin\app”
  3. In folder “vendor\bin” using Notepad edit file “phinx”:
    change line
    $app = require DIR . ‘/…/app/phinx.php’;
  4. to (remove the dots and extra / in the path)
  5. $app = require DIR . ‘/app/phinx.php’;
  6. In folder “vendor\bin\app” using Notepad edit file “phinx.php”:
    change line
    $autoloader = require DIR . ‘/…/src/composer_autoloader.php’;
  7. to (remove the dots and extra / in the path)
  8. $autoloader = require DIR . ‘/src/composer_autoloader.php’;

cd into your installation folder C:\XIBO_CMS
Run this command again:

php vendor\bin\phinx migrate -c phinx.php

IMPORTANT NEXT STEP:
Your previous default web site settings will need to be re-applied or you will get an error 404 on login attempt

Re-Configure IIS Settings:
Launch IIS Manager

-> Default Web Site->Default Document
Add -> “index.php” (if missing from list)

Move to the top of the list “index.php” otherwise you will get HTTP 500 error when starting the install.php

-> Default Web Site-> Request Filtering
Edit Feature Settings…
Set Maximum Query String (Bytes) to 4096 (otherwise you will get datatables.ajax error)
Set Maximum allowed content length (Bytes) (3000000 to 30000000) (Add one more zero)

-> Default Web Site->URLRewrite
Import Rules
Browse the Configuration files and import the .htaccess file in C:\XIBO_CMS\web
Click “Import”
(remove the problem line and import by placing a “#” comment in the front of the code)
Click on “Apply” to make changes

Launch "Task Scheduler"
Start the “XiboXMRstartup” task in “Task Scheduler”

Launch "IIS Manager"
Start your IIS “Xibo” CMS web site