Upgrade xibo to 2.1.0


System :
-Windows Server 2012 R2
-Actual CMS : 2.0.1

I try to update Xibo. So, i follow the instruction from this page : https://xibo.org.uk/docs/setup/upgrade-manual-custom-install

I have no ouput errors but when I try go to the login page, I have this message :

“The CMS is temporarily off-line as an upgrade is in progress. Please check with your system administrator for updates or refresh your page in a few minutes.”

I run the following command : “php vendor/bin/phinx migrate -c phinx.php” in the new xibo files, there is no output errors but I have still the message of upgrade in progress.

In the forum, I found a .bat to put in ‘vendor/bin’ file but it’s not working for me.

What I need to do ?

Thanks in advance,

Hi Franck,

Did you get this to work ? I’m having the same issue …


Hi Stefaan,

I try to do my best but I have no solution at the moment…

I Found it :stuck_out_tongue:

the windows batch file is located deepx in the vendor/robmorgan subfolder … I ran it and the migration went without errors !

Can you give me more details about your solution ?

Hello Franck,

There is not much to add … I just ran the batch file which is located in the vendor/robmorgan subfolder (in stead of the one in the root folder).

Hope this helps you.


Hello Stefaan,

Thanx for your anwser but it’s not working for me. I try to found another solution.

Thank you again !

I found a solution with this post :